Wéi installéiere Klammern op Debian / Ubuntu an Derivaten

Klammeren

Brackets ass e Code Editor dee mir fir eis Gnu / Linux Verdeelung gratis kréie kënnen. Klammeren Et gëtt vun der Adobe Firma erstallt obwuel et Free Software ass.

Brackets ass kee Code Editor fir ze benotzen well et nëmmen erlaabt Ännerung vu Webentwécklung bezunn Dateien, och wann Dateie vu Programméierungssproochen wéi C oder Java och mat dësem Editor erstallt kënne ginn, awer et genéisst net déi selwecht Funktiounen wéi wa mir php oder javascript Dateien erstellen.

Brackets ënnerstëtzt Plugins an Add-ons déi et erlaaben hir Funktiounen an Tools auszebauen awer dat interessantst ass d'Live View déi se bitt. Dës Funktioun erlaabt eis all Webentwécklung ze gesinn déi mir editéieren. Et ass eng vun de Funktiounen déi ech am meeschten iwwer dësen Editor gär hunn an dat mécht mech et ze wielen ier aner Code Editoren wéi Atom oder Sublime Text.

Brackets huet eng Live View Funktioun déi eis hëlleft eise Webprojet z'entwéckelen

Déi lescht Versioun vu Brackets kann an eiser Debian-baséiert Verdeelung installéiert ginn, dofir musse mir just goen déi offiziell Websäit an den Deb Package eroflueden deen eiser Plattform entsprécht. Awer a verschidde Verdeelunge wéi Ubuntu kann dës Installatiounsmethod lästeg sinn wéi Klammer brauch d'Bibgcrypt11 Bibliothéik an Ubuntu huet et net a senge rezentste Versiounen.

Fir dëse Problem ze léisen, installéiere mir entweder d'Bibliothéik onofhängeg oder mir benotzen e Standard-Repository deen dëse Problem léist. Ech entscheede perséinlech fir déi lescht a fir de webupd8 Repository, e Repository deen all eisen Ufuerderungen entsprécht. Also maache mir en Terminal a schreiwe folgend:

sudo add-apt-repository ppa:webupd8team/brackets
sudo apt update
sudo apt install brackets

Mat dësem gëtt de Brackets Editor installéiert an no e puer Minutten Installatioun hu mir et fäerdeg ze benotzen an eis Webapplikatiounen ze kreéieren, ass et net?

UPDATERT: Adobe huet gestoppt Brackets z'entwéckelen no engem Accord mat Microsoft den 1. September 2021, an zënterhier gëtt et keng aktualiséiert Versioun fir Linux. Jo mir kënnen installéieren wat hei erkläert gëtt (v1.13), de Package Snap (v1.11) an der Flatpak (v1.14.1). Méi Informatiounen, hei.

Den Inhalt vum Artikel hält sech un eis Prinzipie vun redaktionnell Ethik. Fir e Feeler ze mellen klickt hei.

6 Kommentaren, loosst ären

Gitt Äre Kommentar

Är Email Adress gëtt net publizéiert ginn. Néideg Felder sinn markéiert mat *

*

*

  1. Responsabel fir d'Donnéeën: AB Internet Networks 2008 SL
  2. Zweck vun den Donnéeën: Kontroll SPAM, Kommentarmanagement.
  3. Legitimatioun: Är Zoustëmmung
  4. Kommunikatioun vun den Donnéeën: D'Donnéeë ginn net un Drëttubidder matgedeelt ausser duerch legal Verpflichtung.
  5. Datenspeicher: Datebank gehost vun Occentus Networks (EU)
  6. Rechter: Zu all Moment kënnt Dir Är Informatioun limitéieren, recuperéieren an läschen.

  1.   angeluz sot

    Exzellenten Brudder, ech krut eng Iddi vum subliméiere mam Kafmessage an ech hu bis elo Atom benotzt awer ech si frou iwwer d'Iddi fir erëm mat engem Tool wéi Dreamweaver ze schaffen.

  2.   inaki sot

    Ech hu relativ kuerz op Ubuntu entwéckelt. Ech benotze momentan Sonnendäischtert. Awer wat ech wierklech vermëssen sinn d'Dreamweaver Templates, datt duerch e Link an engem Menu aktualiséiert gëtt dëst an all de Dateien aktualiséiert déi dës Schabloun benotzen. Gëtt et eppes ähnleches tëscht Klammen oder engem aneren Ide oder Editeur?

  3.   Äis sot

    mmm Ech hunn e méi kompletten Tutorial op mengem Blog hannerlooss, wann Dir interesséiert sidd, ouni de ppa derbäi ze bauen. Wann Dir interesséiert sidd, loosst se wëssen xD

    1.    Jesus sot

      awer deelt Äre Blog, et wier ganz hëllefräich, ech sinn besonnesch op der Sich no engem Editor deen Java Packagen händelt oder un den jdk 8 oder openJDK JRE gebonnen ass.

      Wat

  4.   Javier Garcia sot

    Virwëtzeg Open Source Uwendung (net Open Source) déi eng veraltete Verschlësselungsbibliothéik brauch, et gëtt eng méi aktuell, libgcrypt1.

  5.   Jose sot

    Ech konnt de Package net fannen ...