Dart 2.14 est livré avec le support Apple M1, de nouveaux opérateurs, des améliorations et plus encore

Google a récemment annoncé le lancement de la nouvelle version du langage de programmation "Fléchette 2.14", qui poursuit le développement d'une branche radicalement repensée de Dart 2 et qui diffère de la version originale du langage Dart par l'utilisation d'un script statique fort.

Dans cette nouvelle version Le support Apple M1 est mis en évidence, l'intégration de nouveaux opérateurs, améliorations de certaines commandes, gestion de la mémoire, dans les règles et bien plus encore.

Pour ceux qui ignorent Dard vous devez savoir que c'est conçu pour offrir de meilleurs résultats grâce à des alternatives à certains problèmes de JavaScript, bien que dans sa présentation aucune référence explicite n'ait été faite JavaScript. Il se veut un outil simple pour des projets plus importants et pour offrir une meilleure sécurité.

Le but de Dart n'est pas de remplacer JavaScript comme principal langage de programmation Web dans les navigateurs Web, mais pour offrir une alternative plus moderne. L'esprit du langage se reflète dans les déclarations de Lars Bak, ingénieur logiciel de Google, qui définit Dart comme un "langage structuré mais flexible pour la programmation Web".

Principales nouveautés de Dart 2.14

Dans cette nouvelle version de Dart 2.4, l'une des nouveautés présentées est que le SDK prend déjà en charge les processeurs Apple M1, ce qui signifie à la fois la possibilité d'exécuter la machine virtuelle Dart, les utilitaires et les composants SDK sur des systèmes dotés d'un processeur Apple Silicon, ainsi que la prise en charge de la compilation de fichiers exécutables pour ces puces.

Une autre nouveauté est dans la commande « dart pub » dans lequel le support a été ajouté pour un nouveau fichier de service ".pubignore" qui vous permet de définir une liste de fichiers à ignorer lors de la publication d'un package dans le référentiel pub.dev. Ces paramètres ne chevauchent pas la liste d'ignorés ".gitignore" (dans certaines situations, pub.dev nécessite de ne pas transférer les fichiers nécessaires dans Git, par exemple les scripts internes utilisés lors du développement).

Dans la bibliothèque standard (Coeur) les méthodes statiques hash, hashAll et hashAllUnordered sont ajoutées à la classe Object, tandis que pour la classe DateTime, en cela la gestion de l'heure locale a été améliorée lors de la conversion d'heures entre l'heure d'été et l'heure d'hiver qui n'est pas un multiple d'une heure.

Également dans Dart 2.14 Des ensembles de règles unifiés sont proposés pour l'analyseur de code (linter), qui fournissent un support simultané pour vérifier la conformité avec les recommandations de style de code pour Dart et le framework Flutter. Pour des raisons historiques, les règles de codage pour Flutter et Dart étaient différentes, et deux ensembles de règles étaient utilisés pour Dart.

Dart 2.14 introduit un nouvel ensemble de règles générales pour le linter par défaut dans les nouveaux projets Dart et le SDK Flutter. Régler comprend des règles de base, des règles supplémentaires recommandées et des directives Flutter spécifiques.

Dans le formateur, des optimisations ont été faites dans le formatage des blocs de code en cascada, ce qui peut améliorer considérablement les performances de formatage et éviter une interprétation ambiguë de l'appartenance des éléments d'expression.

Le package ffi ajoute la prise en charge de l'allocateur de mémoire, qui libère les ressources automatiquement. Le package ffigen ajoute la possibilité de générer des définitions de typedef de types Dart à partir du langage C.

Parmi les autres changements qui ressortent:

  • Un nouvel opérateur triple décalage (>>>) a été ajouté qui, contrairement à l'opérateur «>>», n'effectue pas de calcul, mais plutôt un décalage logique qui fonctionne quel que soit le bit de signe (le décalage est effectué sans division en positif et négatif Nombres).
  • Suppression de la restriction sur les arguments de type, qui ne permettait pas d'utiliser des types de fonctions courants comme argument avec un type.
  • Des travaux ont été effectués pour améliorer les performances de la commande "dart test", qui ne nécessite désormais plus de recompilation des tests après modification de pubspec, si le numéro de version n'a pas changé.
  • La prise en charge de la compilation en mode de compatibilité ECMAScript 5 a été supprimée (le changement entraînera la perte de compatibilité avec le navigateur IE11).
  • Les utilitaires distincts stagehand, dartfmt et dart2native ont été dépréciés, remplacés par des commandes intégrées appelées via l'utilitaire dart.
  • Mécanisme d'extensions natives de VM obsolètes. Pour appeler du code natif à partir du code Dart, il est recommandé d'utiliser le nouveau Dart FFI (Foreign Function Interface).

source: https://medium.com


Le contenu de l'article adhère à nos principes de éthique éditoriale. Pour signaler une erreur, cliquez sur c'est par ici !.

Soyez le premier à commenter

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée.

*

*

  1. Responsable des données : AB Internet Networks 2008 SL
  2. Finalité des données: Contrôle du SPAM, gestion des commentaires.
  3. Légitimation: votre consentement
  4. Communication des données: Les données ne seront pas communiquées à des tiers sauf obligation légale.
  5. Stockage des données: base de données hébergée par Occentus Networks (EU)
  6. Droits: à tout moment, vous pouvez limiter, récupérer et supprimer vos informations.