如何在Gnu / Linux上安装Gimp 2.10

Gimp 2.10截图

经过几年的开发,几天前发布了Gimp的新版本Gimp 2.10。 该版本具有很大的改进,并具有许多用户长期以来期望和期望的元素。

用户 滚动发行发行版的计算机上可能已经有此新版本但是那些不使用滚动发行版的人会做什么呢? 接下来,我们将解释在支持存储库,AppImage软件包和flatpak软件包的不同发行版中安装Gimp 2.10的不同方法。安装Gimp 2.10的最简单方法是 通过AppImage包。 我们可以通过以下方式构建此Gimp程序包: 这个Github仓库。 在此存储库中,我们将找到有关以AppImage格式构建软件包的说明。

如果我们有一个基于Ubuntu或Debian的发行版,我们可以 使用PPA存储库,发行版的一些外部存储库将帮助我们安装最新版本的Gimp。 为此,我们打开一个终端并输入以下内容:

sudo add-apt-repository ppa:otto-kesselgulasch/gimp
sudo apt-get update
sudo apt-get install gimp o sudo apt-get upgrade

应该注意的是,该存储库不是官方的,因此可能会给我们安装的某些程序带来一些问题。

第三种选择 通过flatpak软件包安装Gimp 2.10。 许多非滚动发行发行版(例如Fedora,OpenSUSE或Ubuntu)都支持这种类型的软件包。 要以这种格式安装,我们可以转到 Flathub 并通过网络浏览器安装或打开终端并输入以下内容:

flatpak install https://flathub.org/repo/appstream/org.gimp.GIMP.flatpakref

最后一个选择是直接从 Gimp官方网站。 当我们下载软件包 它将是tar.gz格式,我们将其解压缩,然后运行名为“ gimp”的应用程序。 此选项是最简单的选项之一,但与发行版的联系最少。

无论如何,通过这些方法中的任何一种,我们都可以安装最新版本的Gimp并尝试使用Photoshop的这种免费替代方法。


本文内容遵循我们的原则 编辑伦理。 要报告错误,请单击 信息.

8条评论,留下您的评论

发表您的评论

您的电子邮件地址将不会被发表。

*

*

  1. 负责资料:AB Internet Networks 2008 SL
  2. 数据用途:控制垃圾邮件,注释管理。
  3. 合法性:您的同意
  4. 数据通讯:除非有法律义务,否则不会将数据传达给第三方。
  5. 数据存储:Occentus Networks(EU)托管的数据库
  6. 权利:您可以随时限制,恢复和删除您的信息。

  1.   马塞洛

    您安装的是2.8,并且更新不起作用。 知道如何升级吗?

  2.   有人

    没错,已经安装了官方存储库中的那个,即2.8
    我不知道要安装该新版本需要做什么。
    问候。

    1.    帕奎托先生

      您可能正在尝试在Unbuntu 2.10上安装Gimp 16.04,这是当今最合乎逻辑的事情。

      但是,似乎Joaquin忘记了检查存储库,因为如果这样做,他会发现2.10仅适用于Ubuntu 18.04和17.10。

      我想在Ubuntu 16.04中可以使用Flatpak软件包安装它,但是我尚未对其进行测试,因此无法确定。 此外,接下来,我们将不得不查看它是否已翻译,是否可以访问已安装的分区等,等等,新软件包格式的常见问题(尽管并非在所有情况下都会发生),例如snap或flatpak。

      如果Joaquín更新文章以澄清此细节,那将是很好的。

      现在,至少对我而言,他从未回答过我,我也不是完全讨厌。

  3.   阿比克斯

    我想要版本2.10,但是它只给我2.8,而flatpak告诉我它安装了版本2.10,但是当我打开时,我只能得到2.8。

  4.   路易斯

    滚动发布发行版还支持snap和flatpak。

  5.   Yo

    在最新版本的Linux Mint中,目前仅提供2.10.18-1版本。

    1.    Pablinux的

      你好。 在官方的Ubuntu存储库中也会发生这种情况。 如果需要最新版本,则必须添加一个非官方的存储库或使用Flatpak版本。 我会推荐Flatpak,它会在同一天更新。

      问候。

  6.   鲁本

    安装 gimp 的很好解释,它工作得很好。 谢谢