如何在 Ubuntu 中强制重新加载未签名的存储库并避免“GPG 错误,请参阅 apt-secure (8)”

GPG 错误或 apt-secure (8)

尽管 Flatpak 软件包日新月异,但我敢说,无论发行版如何,我们大多数人仍然更喜欢存储库软件。 出于这个原因,例如,在 Ubuntu 中添加一个存储库来拥有最新版本的 OBS工作室 具有最新的依赖项。 但是如果我们这样做并看到文本会怎样 “GPG 错误”? 这是有解决方案的东西。

当我们看到 GPG 错误或要求我们查看 apt-secure (8) 手册页时,发生的事情是 我们正在尝试使用未签名的存储库,或者它根本不适用于我们的 Debian / Ubuntu 版本。 例如,如果我们使用的系统不再接收或尚不受支持,例如目前正在开发的 Ubuntu 22.04 Jammy Jellifish,就会发生这种情况。 请记住,在强制充值时,我们将跳过安全警告,因此您必须小心。 即使我们使用官方来源,例如 OBS 或 Pipewire,某些东西也可能会停止工作。 这不是一个新错误,但我们在 LxA 上没有任何相关内容。

通过编辑 sources.list 文件避免 GPG 错误

这样做非常简单。 这里我们以 Pipewire 仓库为例,据说最新版本的 Kooha 卡死问题解决了(我在 Jammy Jellyfish 中不是这样的……)。 为了 强制重装,我们将执行以下操作:

  1. 我们必须在/etc/apt中的sources.list文件中添加存储库,所以最快的方法是打开终端并写入:
sudo nano /etc/apt/sources.list
  1. 我们输入用户的密码。
  2. 现在,最后我们将添加存储库并将其标记为受信任。 在 Pipewire 的情况下,对于 Ubuntu的21.10或 22.04,由于没有“jammy”选项,我们将添加以下内容:
deb [trusted=yes] http://ppa.launchpad.net/pipewire-debian/pipewire-upstream/ubuntu/ hirsute main
  1. 添加上述内容后,我们按Ctrl + O保存,Enter确认和Ctrl + X退出。

从我们输入的内容来看,“[trusted = yes]”是什么 将其标记为值得信赖,然后存储库 URL 变为“hirsute”将是版本标记,在 Ubuntu 的情况下为 21.10。 正如我们已经解释过的,它也可以在 Ubuntu 22.04 中运行,在那里它会给出一个错误,因为它不适用于将于明年 XNUMX 月发布的版本。

这就是全部。 它是 简单的过程 这可以为我们省去很多麻烦,但我们不应该排除它给我们带来另一个麻烦的可能性。 就个人而言,我只会将它推荐用于我们需要的软件,并且无法通过其他方式获得,但有解释。


本文内容遵循我们的原则 编辑伦理。 要报告错误,请单击 信息.

成为第一个发表评论

发表您的评论

您的电子邮件地址将不会被发表。 必填字段标有 *

*

*

  1. 负责资料:AB Internet Networks 2008 SL
  2. 数据用途:控制垃圾邮件,注释管理。
  3. 合法性:您的同意
  4. 数据通讯:除非有法律义务,否则不会将数据传达给第三方。
  5. 数据存储:Occentus Networks(EU)托管的数据库
  6. 权利:您可以随时限制,恢复和删除您的信息。