在Ubuntu和其他发行版中删除损坏的软件包

破损的包裹

当然在某些情况下,您可能会遇到 破损的包裹。 如果是这样,并且您拥有Debian / Ubuntu发行版或基于它们的发行版,则可以按照本教程中的步骤以相当简单的方式解决这些问题。 这样一来,他们就不会再对您造成困扰了...

但首先,你应该知道 这些是什么 破损的包裹(如果您还不知道的话)。 好吧,有时可能由于某种原因而无法正确安装某个软件包,或者该软件包与它所依赖的其余软件包不兼容。 如果发生这种情况,您将无法从发行版中更新,安装或卸载任何软件包。 造成所有麻烦的软件包就是所谓的损坏的软件包...

MGI 原因 为什么给出破损的包裹可以是:

  • 您试图在发行版的正式存储库外部安装程序。
  • 程序的安装被意外中断。 不管是什么原因。
  • 或操作系统的更新被中断。
  • 还有其他原因,尽管以上是最常见的...

修复损坏的包裹问题

无论是什么原因,您都必须修复它,以使所有内容继续正常运行。 要解决此常见问题,您只需遵循以下步骤 简单的步骤...

误差

您可能已经看到您正在尝试在 典型的错误 类型:

  • 无法获取锁/ var / lib / dpkg /锁
  • 无法锁定目录/ var / lib / apt /列表/

有能力去 整理 您可以运行以下命令:

sudo rm /var/lib/apt/lists/lock
sudo rm /var/cache/apt/archives/lock

修复dpkg问题

使用低级软件包管理工具时,很可能 的dpkg 你得到了错误:

  • dpkg:处理软件包[package_name](–purge)时出错

修理它 如果您不知道引起问题的软件包名称,则可以执行以下操作:

sudo dpkg –configure -a
sudo dpkg –remove –force-remove –reinstreq

相反, 如果你知道名字 试试这个:

sudo mv /var/lib/dpkg/info/nombre_de_tu_paquete.* /tmp/
sudo dpkg –remove –force-remove-reinstreq nombre_de_tu_paquete

记住要替代 your_package_name 根据引起问题的软件包名称...

解决APT问题

另一种方法是使用高级包管理器APT。 为此,首先请确保没有新版本的软件包:

sudo apt –fix-missing update

如果没有,请尝试 运行 命令:

sudo apt install -f
sudo apt update


本文内容遵循我们的原则 编辑伦理。 要报告错误,请单击 信息.

成为第一个发表评论

发表您的评论

您的电子邮件地址将不会被发表。 必填字段标有 *

*

*

  1. 负责资料:AB Internet Networks 2008 SL
  2. 数据用途:控制垃圾邮件,注释管理。
  3. 合法性:您的同意
  4. 数据通讯:除非有法律义务,否则不会将数据传达给第三方。
  5. 数据存储:Occentus Networks(EU)托管的数据库
  6. 权利:您可以随时限制,恢复和删除您的信息。