WiFi hostapd AP приложение для создания точек доступа Wi-Fi в Linux

Wi-Fi-hostapd

Hostapd WiFi AP это небольшое приложение, написанное на C ++ QT, это графическое приложение, созданное для создания временных точек доступа стандарта 802.11b / g (WiFi) на настольных компьютерах и ноутбуках.

Hostapd WiFi AP это совершенно бесплатно и с открытым исходным кодом Это программное обеспечение выпущено под лицензией GNU General Public License версии 2.0 (GPLv2). разработан для облегчения настройки программного обеспечения и соединения Wi-Fi в различных средах операционных систем GNU / Linux.

С точкой доступа Wi-Fi hostapd можно быстро настроить точку доступанапример ноутбук с картой WiFi.

Это приложение дает нам возможность предоставлять доступ в Интернет для других устройств если нет роутера или для тех, кто не может создать точку доступа с помощью NetworkManager или Wicd.

Чтобы создать точку доступа с Wi-Fi hostapd AP использует возможности общедоступных сервисов hostapd, который является системным демоном, который обеспечивает поддержку механизмов аутентификации. AEE 802.11 в точку доступа, IEEE 802.1X / WPA / WPA2 / EAP / RADIUS для точек беспроводного доступа.

И Dnsmasq это инструмент, который сочетает в себе простой DNS и кеширование DHCP / BOOTP на сервере, который поддерживает DNS для частной сети.

Хост-точка доступа Wi-Fi Поддерживает протоколы шифрования WPA, WPA2, WPA3 и WEP, это поддерживает создание скрытых сетей и визуализацию статистики (количество трафика, скорость и отображение списка подключенных клиентов)

Среди основных особенностей этого приложения можно выделить:

  • Создайте точку доступа Wi-Fi в несколько кликов
  • WPA + WPA2 (WPA3) и поддержка шифрования WEP
  • Поддержка скрытых сетей
  • Предустановка по умолчанию
  • Маска файлов конфигурации
  • Подсчет трафика, скорость, показать список клиентов.

Как установить точку доступа WiFi hostapd в Linux?

Wi-Fi-hostapd-AP-009

Чтобы установить этот инструмент в вашей системе, вы должны следовать следующим инструкциям.

Si пользователи Debian, Ubuntu, Linux Mint или любой другой дистрибутив, полученный из этих, мы можем загрузить следующие пакеты, чтобы установить их в системе.

Мы должны открыть терминал с помощью Ctrl + Alt + t и выполнить в нем следующую команду в соответствии с архитектурой вашей системы.

Тем, у кого есть 64-битные системы, они должны ввести следующее:

wget https://launchpad.net/~ekozincew/+archive/ubuntu/ppa/+files/wifi-hostapd-ap_1.1.1-0~1~ubuntu15.04.1_amd64.deb

В то время как для тех, кто является пользователями 32-битных систем, они могут скачать пакет с:

wget https://launchpad.net/~ekozincew/+archive/ubuntu/ppa/+files/wifi-hostapd-ap_1.1.1-0~1~ubuntu15.04.1_i386.deb

После того, как пакет был загружен, мы приступаем к установке приложения с помощью следующей команды:

sudo dpkg -i wifi-hostapd-ap*.deb

Если у нас есть проблемы с зависимостями, мы можем решить их, выполнив в терминале:

sudo apt-get install -f

Если у нас все еще есть проблемы с зависимостями, мы можем установить следующее с помощью этой команды:

sudo apt-get install wireless-tools puente-utils hostapd dnsmasq libqtgui4

к случай тех, у которых есть системы с поддержкой пакетов RPM такие как Fedora, CentOS, RHEL, openSUSE или любой другой дистрибутив, созданный на их основе, мы можем скачать пакет rpm.

Для этого Мы должны открыть терминал в нашей системе и выполнить в нем следующую команду:

wget https://build.opensuse.org/package/binary/download/home:DarkSS/wifi-hostapd-ap/openSUSE_Leap_15.0/x86_64/wifi-hostapd-ap-1.1.1-lp150.7.1.x86_64.rpm

Y мы можем установить этот загруженный пакет с помощью команды:

sudo rpm -ivh wifi-hostapd-ap-1.1.1-lp150.7.1.x86_64.rpm

Наконец, для особого случая openSUSE мы можем добавить в систему следующий репозиторий, чтобы установить из него это приложение.

Для тех, кто Пользователи openSUSE Tumbleweed запустите следующее от имени root:

zypper addrepo https://download.opensuse.org/repositories/home:DarkSS/openSUSE_Tumbleweed/home:DarkSS.repo

zypper refresh

zypper install wifi-hostapd-ap

В случае если Пользователи openSUSE Leap 42.3 запустите следующее от имени root:

zypper addrepo https://download.opensuse.org/repositories/home:DarkSS/openSUSE_Leap_42.3/home:DarkSS.repo

zypper refresh

zypper install wifi-hostapd-ap

Наконец для Пользователи openSUSE Leap 15.0 запустите следующее от имени root:

zypper addrepo https://download.opensuse.org/repositories/home:DarkSS/openSUSE_Leap_15.0/home:DarkSS.repo

zypper refresh

zypper install wifi-hostapd-ap

Скачать исходный код

Для остальных дистрибутивов у нас есть возможность загрузить исходный код приложения и скомпилировать его в нашей системе.

Нам нужно только загрузить его с помощью терминала, выполнив следующую команду:

wget https://storage.googleapis.com/google-code-archive-downloads/v2/code.google.com/wifi-hostapd-ap/WiFi_Hostapd_AP_1.1.tar.gz

И все, мы можем начать использовать это приложение в нашей системе.


Содержание статьи соответствует нашим принципам редакционная этика. Чтобы сообщить об ошибке, нажмите здесь.

5 комментариев, оставьте свой

Оставьте свой комментарий

Ваш электронный адрес не будет опубликован.

*

*

  1. Ответственный за данные: AB Internet Networks 2008 SL
  2. Назначение данных: контроль спама, управление комментариями.
  3. Легитимация: ваше согласие
  4. Передача данных: данные не будут переданы третьим лицам, кроме как по закону.
  5. Хранение данных: база данных, размещенная в Occentus Networks (ЕС)
  6. Права: в любое время вы можете ограничить, восстановить и удалить свою информацию.

  1.   Шупакабра сказал

    Это должно быть включено по умолчанию во все дистрибутивы.

  2.   лепронет сказал

    Здравствуйте, в Ubuntu или Kubuntu это можно легко настроить в настройках сети (создать новое общее соединение Wi-Fi) Приветствую.

  3.   Эдуардо сказал

    Привет, с ubuntu mate 20.04 я не мог поделиться Wi-Fi ни с одной из инструкций, мне удалось обнаружить сеть другими устройствами, но после десятков тестов он всегда говорит: «проверьте пароль и попробуйте еще раз», сейчас я пытаюсь установить это и всегда получаю
    «При обработке обнаружены ошибки:
    Wi-Fi-hostapd-ap »
    Я несколько расстроен, оборудование для любого другого нормального использования в порядке
    Любое предложение?

  4.   Эдуардо сказал

    Я выполнил все шаги и не смог установить его в ubuntu mate 20.04, в любом случае спасибо, я не могу найти альтернативу и не могу ее решить

  5.   Эдуардо сказал

    Я снова, прежде чем я пробовал с ubuntu, теперь с mint, я просто не могу его установить, я выполняю шаги как есть, но он не устанавливается:

    Ноутбук HP-250-G6: ~ $ wget https://launchpad.net/~ekozincew/+archive/ubuntu/ppa/+files/wifi-hostapd-ap_1.1.1-0~1~ubuntu15.04.1_amd64.deb
    –2020-07-31 20:12:32– https://launchpad.net/~ekozincew/+archive/ubuntu/ppa/+files/wifi-hostapd-ap_1.1.1-0~1~ubuntu15.04.1_amd64.deb
    Разрешение launchpad.net (launchpad.net)… 91.189.89.222, 91.189.89.223, 2001: 67c: 1560: 8003 :: 8003,…
    Подключение к launchpad.net (launchpad.net) | 91.189.89.222 |: 443… подключено.
    HTTP-запрос отправлен, ожидает ответа… 303 См. Другое
    Местонахождение: https://launchpadlibrarian.net/191115296/wifi-hostapd-ap_1.1.1-0~1~ubuntu15.04.1_amd64.deb [следующий]
    –2020-07-31 20:12:37– https://launchpadlibrarian.net/191115296/wifi-hostapd-ap_1.1.1-0~1~ubuntu15.04.1_amd64.deb
    Разрешение запуска launchpadlibrarian.net (launchpadlibrarian.net)… 91.189.89.229, 91.189.89.228, 2001: 67c: 1560: 8003 :: 8008,…
    Подключение к launchpadlibrarian.net (launchpadlibrarian.net) | 91.189.89.229 |: 443… подключено.
    HTTP-запрос отправлен, ожидает ответа… 200 OK
    Длина: 582670 (569 КБ) [application / x-debian-package]
    Saving to: ‘wifi-hostapd-ap_1.1.1-0~1~ubuntu15.04.1_amd64.deb’

    wifi-hostapd-ap_1.1 100% [===================>] 569,01 КБ 5,42 КБ / с за 1 мин 49 с

    2020-07-31 20:14:33 (5,21 КБ / с) - 'wifi-hostapd-ap_1.1.1-0 ~ 1 ~ ubuntu15.04.1_amd64.deb' сохранен [582670/582670]

    Ноутбук HP-250-G6: ~ $ sudo dpkg -i wifi-hostapd-ap * .deb
    [sudo] пароль для:
    Выбор ранее невыбранного пакета wifi-hostapd-ap.
    (Чтение базы данных… В настоящее время установлено 391697 файл или каталог.)
    Подготовка к распаковке wifi-hostapd-ap_1.1.1-0 ~ 1 ~ ubuntu15.04.1_amd64.deb…
    Распаковка wifi-hostapd-ap (1.1.1-0 ~ 1 ~ ubuntu15.04.1)…
    dpkg: проблемы с зависимостями не позволяют настроить wifi-hostapd-ap:
    wifi-hostapd-ap зависит от bridge-utils; Тем не мение:
    Пакет `bridge-utils 'не установлен.
    wifi-hostapd-ap зависит от hostapd; Тем не мение:
    Пакет hostapd не установлен.
    wifi-hostapd-ap зависит от dnsmasq; Тем не мение:
    Пакет `dnsmasq 'не установлен.
    wifi-hostapd-ap зависит от libqtgui4 (> = 4.7); Тем не мение:
    Пакет `libqtgui4 'не установлен.

    dpkg: ошибка обработки пакета wifi-hostapd-ap (–install):
    проблемы с зависимостями - оставлено ненастроенным
    Обработка триггеров для hicolor-icon-theme (0.17-2) ...
    Обработка триггеров для настольных файловых утилит (0.24 + linuxmint1) ...
    Обработка триггеров для поддержки mime (3.64ubuntu1) ...
    При обработке обнаружены ошибки:
    Wi-Fi-hostapd-ap

    Ноутбук HP-250-G6: ~ $ sudo apt-get install -f
    Чтение списка пакетов ... Готово
    Создание дерева зависимостей
    Чтение информации о статусе ... Готово
    Исправление зависимостей ... Готово
    Следующие пакеты БУДУТ УДАЛЕНЫ:
    Wi-Fi-hostapd-ap
    0 обновлено, 0 будет установлено, 1 удалено и 9 не обновлено.
    1 не полностью установлен или удален.
    После этой операции будет освобождено 998 КБ.
    Вы хотите продолжить? [Д / Н] да
    (Чтение базы данных… В настоящее время установлено 391710 файл или каталог.)
    Удаление wifi-hostapd-ap (1.1.1-0 ~ 1 ~ ubuntu15.04.1)…
    Обработка триггеров для поддержки mime (3.64ubuntu1) ...
    Обработка триггеров для hicolor-icon-theme (0.17-2) ...
    Обработка триггеров для настольных файловых утилит (0.24 + linuxmint1) ...

    HP-250-G6-Notebook-PC: ~ $ sudo apt-get install wireless-tools bridge-utils hostapd dnsmasq libqtgui4
    Чтение списка пакетов ... Готово
    Создание дерева зависимостей
    Чтение информации о статусе ... Готово
    Пакет libqtgui4 недоступен, но некоторые другие ссылки на пакеты
    к. Это может означать, что пакет отсутствует, устарел или только
    доступно из другого источника

    E: Не удалось найти пакет bridge-utils
    E: Пакет "libqtgui4" не имеет кандидата на установку.

    Любое предложение?
    Saludos у Gracias

bool (истина)