Как установить поддержку Vulkan API в Linux?

Вулкан
Vulkan - это кроссплатформенный API для разработки приложений с 3D-графикой. Впервые об этом было объявлено на GDC в 2015 году компанией Khronos Group. Первоначально он был представлен Хроносом как «инициатива OpenGL следующего поколения», но затем название было отброшено, оставив Vulkan в качестве окончательного.

Vulkan основан на Mantle, другом API от компании AMD, код которого был передан Khronos с целью создания открытого стандарта, аналогичного OpenGL, но на низком уровне.

Его главная особенность заключается в том, что он может использовать преимущество количества ядер, присутствующих в основном процессоре ПК, резко увеличивая графическую производительность.

Vulkan призван обеспечить ряд преимуществ по сравнению с другими API, а также перед своим предшественником OpenGL.. Vulkan предлагает меньше накладных расходов, более прямой контроль над графическим процессором и меньшую загрузку процессора. Общая концепция и набор функций Vulkan аналогичен Directx 12, Metal и Mantle.

Установка Vulkan в Linux

Прежде чем приступить к установке, Важно изучить совместимость Vulkan с вашим графическим процессором, поскольку не все модели поддерживаются. Это делается за ваш счет, и вам следует зайти на сайт производителя вашего графического процессора и посмотреть спецификации совместимости.

Также необходимо иметь в нашем дистрибутиве последние стабильные видеодрайверы, где можно использовать как открытые, так и частные контроллеры, это дело вкуса.

Установка на Debian

Для тех, кто является пользователями Debian или любого другого дистрибутива на его основе, Вы должны выполнить одну из следующих команд, чтобы установить Vulkan в вашу систему.

Для тех, кто пользуется AMD GPU:

sudo apt install libvulkan1 mesa-vulkan-drivers vulkan-utils

Теперь для тех из вас, кто пользуется графическим процессором Nvidia:

sudo apt install vulkan-utils

Установка в Ubuntu и производных

Те, кто являются пользователями Ubuntu, Linux Mint, Elementary OS или любой другой производной Ubuntu. Они могут выполнить установку способом, очень похожим на Debian, только здесь мы будем использовать для этого репозитории.

Во-первых, кем бы они ни были Пользователи AMD GPU должны добавить следующий репозиторий:

sudo add-apt-repository ppa:oibaf/graphics-drivers
sudo apt update
sudo apt upgrade

Я установил позже:

sudo apt install libvulkan1 mesa-vulkan-drivers vulkan-utils

Теперь для всех Пользователи Nvidia GPU просто добавляют этот репозиторий:

sudo add-apt-repository ppa:graphics-drivers/ppa
sudo apt update
sudo apt upgrade

А затем мы устанавливаем с помощью:

sudo apt install nvidia-graphics-drivers-396 nvidia-settings vulkan vulkan-utils

Установка на Fedora

Для тех, кто пользуется Fedora, а также производными от нее дистрибутивами. Вы можете установить Vulkan API в своей системе, следуя инструкциям в соответствии с вашим графическим процессором.
Те, у кого есть графические процессоры AMD, должны выполнить следующую команду:

sudo dnf install vulkan vulkan-info

Пользователи с графическими процессорами Nvidia должны запустить в терминале следующее:

sudo dnf install https://download1.rpmfusion.org/free/fedora/rpmfusion-free-release-$(rpm -E %fedora).noarch.rpm https://download1.rpmfusion.org/nonfree/fedora/rpmfusion-nonfree-release-$(rpm -E %fedora).noarch.rpm

А позже, чтобы установить графический API Vulkan, мы собираемся выполнить в терминале следующее:

sudo dnf install xorg-x11-drv-nvidia akmod-nvidia vulkan vulkan-tools

Установка в openSUSE

В случае тех, кто является пользователями любой версии openSUSE, мы собираемся установить Vulkan API, выполнив в терминале следующее.
Пользователи AMD GPU:

sudo zypper in vulkan libvulkan1 vulkan-utils mesa-vulkan-drivers

Пользователи графического процессора Nvidia:

sudo zypper in vulkan libvulkan1 vulkan-utils

Установка на Arch Linux и производных

Наконец, для тех, кто является пользователями Arch Linux, Manjaro Linux, Antergos или любой другой производной от Arch Linux, они смогут установить этот API следующим образом.

В конкретном случае этого дистрибутива Linux вы должны знать, что установка видеодрайверов ваших графических процессоров немного отличается от того, что можно сделать в других дистрибутивах.

Как вы знаете, в случае графических процессоров AMD существуют пакеты Radeon или AMDGPU Pro, поэтому здесь у нас есть несколько вариантов для Vulkan API.

Сначала для тех, у кого есть графические процессоры Intel, они собираются установить следующее:

sudo pacman -S vulkan-intel

Теперь для пользователей AMD GPU, но с драйверами Radeon установите следующее:

sudo pacman -S vulkan-radeon

В другом случае от AMD, но с использованием драйверов AMDGPU Pro, это будет сделано из AUR.

yay -S amdgpu-pro-vulkan

Наконец, чтобы проверить установку, мы выполняем:

glxinfo | grep -i vulkan

Содержание статьи соответствует нашим принципам редакционная этика. Чтобы сообщить об ошибке, нажмите здесь.

2 комментариев, оставьте свой

Оставьте свой комментарий

Ваш электронный адрес не будет опубликован. Обязательные для заполнения поля помечены *

*

*

  1. Ответственный за данные: Мигель Анхель Гатон
  2. Назначение данных: контроль спама, управление комментариями.
  3. Легитимация: ваше согласие
  4. Передача данных: данные не будут переданы третьим лицам, кроме как по закону.
  5. Хранение данных: база данных, размещенная в Occentus Networks (ЕС)
  6. Права: в любое время вы можете ограничить, восстановить и удалить свою информацию.

  1.   Альбрехт сказал

    Доброе утро, этот api также полезен для APU или только для выделенных видеокарт?

  2.   Джеймс Сенсеб сказал

    Когда я хочу установить vulkan, мне кажется, что это
    sudo apt установить nvidia-graphics-drivers-396 nvidia-settings vulkan vulkan-utils
    Чтение списка пакетов ... Готово
    Создание дерева зависимостей
    Чтение информации о статусе ... Готово
    E: Не удалось найти пакет nvidia-graphics-drivers-396
    E: Не удалось найти пакет vulkan
    и я не могу использовать vulkan на моем компьютере.