Cawbird, клиент GTK с открытым исходным кодом для Twitter, достигает своей версии 1.3.1.

Несколько дней назад Cawbird 1.3.1 Выпущен выпуск корректирующей версии что исправляет некоторые проблемы с аварийным поведениемПомимо включения некоторых улучшений и исправлений для загрузки мультимедиа и мобильных устройств.

Тем, кто не знаком с Cawbird, следует знать, что это современный и легкий клиент Twitter для рабочего стола GNOME 3. Он включает в себя предварительный просмотр видео и изображений в Интернете, создание списков и избранных, фильтрацию твитов и полнотекстовый поиск. Cawbird может управлять несколькими учетными записями Twitter.

Cawbird - это форк Corebird, которая перестала поддерживаться после того, как Twitter отключил потоковый API. Cawbird работает с новыми API и включает в себя некоторые исправления и модификации которые исторически были исправлены в пользовательскую сборку Corebird IBBoard в вашей личной учетной записи Open Build Service.

Хотя следует учитывать, что Из-за изменений в API Twitter Cawbird имеет следующие ограничения:

  • Cawbird будет обновляться каждые две минуты
  • Cawbird не уведомляется о следующем, которое будет обновлено при перезагрузке:
  • Продолжить отписаться
  • Заблокировать разблокировать
  • Отключить / включить
  • Удаление DM
  • Некоторые изменения в списке

Что нового в Cawbird 1.3.1?

Из улучшений, которые были внесены в эту новую корректирующую версию Cawbird 1.3.1, мы можем обнаружить, что улучшена возможность скрыть все твиты в представлении профиля при блокировке или отключении звука пользователя.

Помимо того, что исправлена ​​разблокировка и активация звука при очистке локального кеша Перед загрузкой временной шкалы или упоминаний были внесены исправления заблокированных или отключенных пользователей и загрузка списков блокировки, чтобы гарантировать, что заблокированные или отключенные твиты будут скрыты при запуске.

также исправлены настройки совмещения твитов и уведомлений чтобы разрешить более узкое диалоговое окно конфигурации для мобильных устройств.

Из других изменений которые выделяются в новой версии:

  • Заполняйте постепенно увеличивающиеся пакеты твитов для профилей на случай, если Деактивировать RT скрывает слишком много твитов, чтобы представление не прокручивалось
  • Предоставляется всплывающее сообщение, объясняющее, почему не удалось загрузить медиа (например, Twitter не поддерживает видеокодек).
  • Звук разблокировки / разблокировки теперь говорит "Разблокировать" или "Звук разблокировки" на кнопке вместо того, чтобы всегда говорить "Разблокировать".
  • Исправьте проверку размера носителя, чтобы видео не выходили из строя из-за того, что они превышают ограничение изображения
  • Более узкий список учетных записей пользователей для узких окон, чтобы избежать переполнения и обрезанной кнопки «профиль».

Наконец, если вам интересно узнать об этом больше об этой новой версии Cawbird, вы можете проверить подробности По следующей ссылке.

Как установить Cawbird в Linux?

Для тех, кто заинтересован в возможности установить этот клиент Twitter в своей системе, они могут сделать это, следуя инструкциям, которые мы делимся ниже.

Важно отметить, что Cawbird находится в репозиториях основных дистрибутивов. Linux, плюс также есть пакеты сообщества на Flatpak и Snap, что делает установку еще проще.

Например, тем, кто хочет установить пакет Flaptak, достаточно выполнить следующую команду:

flatpak install --user https://flathub.org/repo/appstream/uk.co.ibboard.cawbird.flatpakref

Что касается тех, кто предпочитает использовать Snap, они могут установить Cawbird из терминала, набрав следующее:

sudo snap install cawbird

Теперь, что касается пакетов для различных дистрибутивов Linux, мы можем выполнить установку в Ubuntu и любой производной от него, набрав в терминале следующее:

echo 'deb http://download.opensuse.org/repositories/home:/IBBoard:/cawbird/xUbuntu_20.04/ /' | sudo tee /etc/apt/sources.list.d/home:IBBoard:cawbird.list
curl -fsSL https://download.opensuse.org/repositories/home:IBBoard:cawbird/xUbuntu_20.04/Release.key | gpg --dearmor | sudo tee /etc/apt/trusted.gpg.d/home_IBBoard_cawbird.gpg > /dev/null
sudo apt update
sudo apt install cawbird

Что касается пользователей Fedora и ее производных:

sudo dnf config-manager--add-repo https://download.opensuse.org/repositories/home:IBBoard:cawbird/Fedora_30/home:IBBoard:cawbird.repo
sudo dnf install cawbird

А для тех, кто пользуется Arch Linux, Manjaro или любой другой производной от Arch Linux:

sudo pacman -Syu cawbird

Напоследок для тех, кто пользуется opensuse:

sudo zypper addrepo https://download.opensuse.org/repositories/home:IBBoard:cawbird/openSUSE_Leap_15.1/home:IBBoard:cawbird.repo
sudo zypper refresh
sudo zypper install cawbird

Содержание статьи соответствует нашим принципам редакционная этика. Чтобы сообщить об ошибке, нажмите здесь.

Комментарий, оставьте свой

Оставьте свой комментарий

Ваш электронный адрес не будет опубликован.

*

*

  1. Ответственный за данные: AB Internet Networks 2008 SL
  2. Назначение данных: контроль спама, управление комментариями.
  3. Легитимация: ваше согласие
  4. Передача данных: данные не будут переданы третьим лицам, кроме как по закону.
  5. Хранение данных: база данных, размещенная в Occentus Networks (ЕС)
  6. Права: в любое время вы можете ограничить, восстановить и удалить свою информацию.

  1.   Seba сказал

    Не беспокойтесь о клиентах для Twitter, которые начали переходить на Parler, Gab и т. Д. И т. Д.
    Что было бы хорошо с этими приложениями, так это то, что они позволяют управлять всеми этими платформами одновременно.