Firefox 66.0.4 прибывает, чтобы решить проблему с надстройками

Недавно Разработчики Mozilla выпустили корректирующие правки полнофункциональный Firefox 66.0.4 и 60.6.2 ESR, которые предлагают обходной путь для замены просроченного промежуточного сертификата и восстановления отключенных подключаемых модулей.

в качестве как мы прокомментировали в предыдущей статье, los Пользователи Firefox заметили проблему в ваших браузерах: они не могли устанавливать расширения, и их существующие плагины больше не работали.

В сообщении в блоге Mozilla сообщила, что выявила проблему и настроила патч для пользователей:

«В прошлую пятницу, 3 мая, мы узнали о проблеме с Firefox, которая помешала запуску или установке новых дополнительных модулей. Приносим извинения за неудобства, причиненные пользователям Firefox.

«Наша команда определила проблему и внедрила исправление для всех пользователей Firefox Desktop на каналах Release, Beta и Nightly. Раствор будет автоматически применяться в фоновом режиме в ближайшие несколько часов.

Теме статьи:
Расширения Firefox больше не могут использоваться из-за недействительного сертификата

Вам не нужно предпринимать активные действия, чтобы плагины снова заработали. В частности, не удаляйте и не переустанавливайте какие-либо плагины, чтобы попытаться решить проблему. При удалении плагина удаляются все связанные с ним данные, в отличие от деактивации и повторной активации.

Firefox по-прежнему не решает проблемы полностью

Несмотря на то, что в этом новом выпуске устранена проблема с сертификатом, остается несколько нерешенных побочных эффектов:

некоторые Плагины, такие как Epubreader, не восстанавливаются в about: надстройки после того, как сертификат был обновлен или остается в неподдерживаемом состоянии.

Проблема касается к плагинам без идентификатора в файле manifest.json которые были удалены в случае ошибки проверки цифровой подписи.

Поэтому рекомендуется переустановить такие дополнения (данные будут восстановлены так, как остались в каталоге с профилем).

Существует потеря данных и настроек в дополнениях, использующих функциональность контейнера context, например, в дополнение к контейнерам с несколькими учетными записями и контейнеру Facebook.

Пользователям рекомендуется перенастроить эти плагины в about: addons.

Темы не восстанавливаются. Пользователям рекомендуется повторно включить их в диспетчере плагинов.

Настройки по умолчанию для домашней страницы и поисковых систем сбрасываются до значений по умолчанию. Пользователю необходимо перенастроить домашнюю страницу и поисковую систему.

Для более старых версий (Firefox 56.0.2 и более ранние версии), которые не включают норманду (компонент для поддержки исследований, проведения опросов и незапланированной активации новых функций), энтузиасты предложили решить проблему путем извлечения сертификата из файла XPI с решением.

Извлеченный сертификат необходимо записать в файл pem и импортировать этот файл через диалоговое окно «Параметры - Конфиденциальность и безопасность - Сертификаты - Просмотр сертификатов - Полномочия - Импорт».

Кроме того, мы можем наблюдать обсуждение зависимости от браузера Tor в инфраструктуре Mozilla.

Поскольку для Пользователи браузера Tor пострадали с прилагаемыми плагинами NoScript и HTTPS-Everywhere, обеспечивающими дополнительный уровень защиты.

Для восстановления достаточно настроить параметры xpinstall.signatures.required = ложь en о: конфиг, но факт использования сторонних экземпляров пользователей браузера Tor вызывает вопросы, действия которых могут отключить дополнительные уровни анонимности.

Как установить Firefox 66.04 в Linux?

Чтобы установить эту новую исправляющую версию браузера, вы можете сделать это, следуя приведенным ниже инструкциям.

Пользователи Ubuntu, Linux Mint или другой производной Ubuntu, Они могут установить или обновить эту новую версию с помощью PPA браузера.

Его можно добавить в систему, открыв терминал и выполнив в нем следующую команду:

sudo add-apt-repository ppa:ubuntu-mozilla-security/ppa -y && sudo apt-get update

Сделано это, теперь им просто нужно установить:

sudo apt install firefox

В случае Пользователи Arch Linux и производные, просто запустите в терминале:

sudo pacman -Syu

Или установить с помощью:

sudo pacman -S firefox

к все остальные дистрибутивы Linux могут загружать двоичные пакеты от по следующей ссылке.  


Содержание статьи соответствует нашим принципам редакционная этика. Чтобы сообщить об ошибке, нажмите здесь.

3 комментариев, оставьте свой

Оставьте свой комментарий

Ваш электронный адрес не будет опубликован.

*

*

  1. Ответственный за данные: AB Internet Networks 2008 SL
  2. Назначение данных: контроль спама, управление комментариями.
  3. Легитимация: ваше согласие
  4. Передача данных: данные не будут переданы третьим лицам, кроме как по закону.
  5. Хранение данных: база данных, размещенная в Occentus Networks (ЕС)
  6. Права: в любое время вы можете ограничить, восстановить и удалить свою информацию.

  1.   Хорхе сказал

    Хорошо выполненные шаги говорят мне, что у меня уже есть последняя версия firefox, и она не обновлена ​​до соответствующей 66.04.

    1.    Дэвид наранхо сказал

      С какого дистрибутива вы это делаете, вы закрывали браузер при обновлении?

  2.   Фернандо Арагон сказал

    Планируете ли вы исправить проблему для версий 56.0.2 и ранее?