Как установить DeepFaceLab в Linux для создания deepfake-видео

Уже несколько лет в Интернете появляются так называемые Deepfake видео, но в последние месяцы его популярность значительно возросла благодаря различным инструментам и приложениям, упрощающим создание.

Deepfake - это метод, используемый для изменения изображений или видео с использованием искусственного интеллекта, в большинстве случаев он используется для наложения одного лица на другое, создавая таким образом поддельные видео с впечатляющими результатами.

Раньше создание deepfake видео было навыком, на освоение которого уходили годы, но теперь, с развитием технологий, это очень легко сделать.

DeepFaceLab - это инструмент, доступный для Linux и других систем, который позволяет очень простым способом создавать deepfake-видео с помощью командной строки.

Может показаться, что использование DeepFaceLab очень сложно в использовании, но все совсем наоборот: просто запустив несколько скриптов, вы можете изменить видео и добавить новое лицо главному герою.

Как установить DeepFaceLab в Linux

Чтобы установить DeepFaceLab, вам необходимо сначала установить Anaconda3 с помощью Официальный сайт а затем вам нужно будет инициализировать его следующими командами:

экспорт PATH = ~ / anaconda3 / bin: $ PATH conda init bash

Теперь вы можете перейти к установке DeepFacebLab со следующими строками кода:

conda create -y -n deepfacelab python = 3.6.6 cudatoolkit = 9.0 cudnn = 7.3.1 conda активировать deepfacelab git clone https://github.com/lbfs/DeepFaceLab_Linux.git cd DeepFaceLab_Linux python -m pip install -r requirements-cuda .текст

Если у вас Ubuntu 16.04 или 18.04, вы можете проверить официальную страницу сборки, чтобы узнать о способах установки DeepFaceLab в обеих системах.

Использование DeepFaceLab может быть непростым делом, но как только вы прочтете это всегда актуальное руководство, вы сможете создавать свои дипфейк-видео как профессионал.

Если у вас возникнут проблемы с установкой или использованием DeepFaceLab, мы с радостью поможем вам в комментариях.


Содержание статьи соответствует нашим принципам редакционная этика. Чтобы сообщить об ошибке, нажмите здесь.

5 комментариев, оставьте свой

Оставьте свой комментарий

Ваш электронный адрес не будет опубликован.

*

*

  1. Ответственный за данные: AB Internet Networks 2008 SL
  2. Назначение данных: контроль спама, управление комментариями.
  3. Легитимация: ваше согласие
  4. Передача данных: данные не будут переданы третьим лицам, кроме как по закону.
  5. Хранение данных: база данных, размещенная в Occentus Networks (ЕС)
  6. Права: в любое время вы можете ограничить, восстановить и удалить свою информацию.

  1.   Ругер сказал

    Как я могу запустить программу после ее установки или как проверить, что она работает?

  2.   ХЮГО ФЕРНАНДО КАРРЕРА ТОАСА сказал

    Спасибо за обмен
    как я решаю следующее.
    ОШИБКА: не удалось найти версию, удовлетворяющую требованию tensorflow-gpu == 1.12.0 (из -r requirements-cuda.txt (строка 5)) (из версий: 1.13.0rc1, 1.13.0rc2, 1.13.1, 1.13.2 .1.14.0, 0rc1.14.0, 1rc1.14.0, 1.15.0, 0rc2.0.0, 0a2.0.0, 0b2.0.0, 1b2.0.0, 0rc2.0.0, 1rcXNUMX)
    ОШИБКА: не найдено подходящего распределения для tensorflow-gpu == 1.12.0 (из -r requirements-cuda.txt (строка 5))
    Помогите мне, пожалуйста

  3.   Рикардо сказал

    Привет,

    Это дает мне ту же ошибку, которую комментирует HUGO FERNANDO CARRERA TOASA

    ОШИБКА: не удалось найти версию, удовлетворяющую требованию tensorflow-gpu == 1.12.0 (из -r requirements-cuda.txt (строка 5)) (из версий: 1.13.0rc1, 1.13.0rc2, 1.13.1, 1.13.2 .1.14.0, 0rc1.14.0, 1rc1.14.0, 1.15.0, 0rc1.15.0, 1rc1.15.0, 2rc1.15.0, 3rc1.15.0, 2.0.0, 0a2.0.0, 0b2.0.0, 1b2.0.0, 0rc2.0.0 , 1rc2.0.0, 2rc2.0.0, XNUMX)
    ОШИБКА: не найдено подходящего распределения для tensorflow-gpu == 1.12.0 (из -r requirements-cuda.txt (строка 5))

  4.   Франсиско Диас Карси сказал

    Привет
    Вы говорите: «Использование DeepFaceLab может быть сложным, но как только вы прочтете это всегда актуальное руководство, вы сможете создавать свои дипфейк-видео как профессионал». но где учебник по использованию?

    Спасибо, привет.

  5.   Билл сказал

    Здравствуйте, доброе утро, я хотел бы знать, может ли кто-нибудь помочь мне с Deepface для Windows 10. Проблема в том, что я загружаю его и, следуя инструкциям видеоурока, устанавливаю драйверы для видеокарты nvidia, cuda_9.0.176 _win10.exe, патч cuda_9.0.176.1_windows.exe, библиотека cudnn-9.0-windows10-x64-v7.6.5.32.zip и программа deepface. Я выполнил все шаги, но когда я открываю программу, я получаю маленькое пустое окошко, в котором написано: Журнал изменений:
    - Автообновления белки
    - Повторно добавлены наборы данных изображений
    - Исправлена ​​ошибка без лица
    - Снова добавлены параметры слияния
    - Обновлен до TF 1.5, CUDA 9
    Не забудьте также загрузить и установить основную библиотеку. Как только оно будет загружено и установлено в соответствии с инструкциями на форуме, перезагрузите приложение, и это сообщение будет
    исчезают.
    То есть программа мне не открывается. Я был бы очень признателен за любую помощь, которую вы можете мне оказать. Очень благодарны. Уильям

bool (истина)