Как принудительно перезагрузить неподписанный репозиторий в Ubuntu и избежать «ошибки GPG, см. Apt-secure (8)»

Ошибка GPG или apt-secure (8)

Хотя пакеты Flatpak набирают популярность с каждым днем, я осмелюсь сказать, что большинство из нас по-прежнему предпочитает программное обеспечение для репозиториев независимо от распространения. По этой причине, например, в Ubuntu легко добавить репозиторий с последней версией OBS Studio с его наиболее актуальными зависимостями. Но что, если мы сделаем это и увидим текст «Ошибка GPG»? Это то, что имеет решение.

Когда мы видим ошибку GPG или просим нас просмотреть страницу руководства apt-secure (8), происходит следующее: мы пытаемся использовать неподписанный репозиторий, или он просто недоступен для нашей версии Debian / Ubuntu. Это может произойти, например, если мы находимся в системе, которая больше не получает или еще не поддерживается, такой как Ubuntu 22.04 Jammy Jellifish, которая сейчас находится в разработке. Имейте в виду, что при принудительном пополнении счета мы пропустим предупреждение системы безопасности, поэтому будьте осторожны с этим. Даже если мы будем использовать официальные источники, такие как OBS или Pipewire, что-то может перестать работать. Это не новая ошибка, но здесь, в LxA, о ней ничего не говорилось.

Чтобы избежать ошибки GPG, отредактируйте файл sources.list

Сделать это довольно просто. Здесь мы собираемся использовать репозиторий Pipewire в качестве примера, в котором говорится, что проблема зависания Kooha в последних версиях решена (это не было моим случаем в Jammy Jellyfish ...). Для принудительная перезагрузка, мы бы сделали следующее:

  1. Мы должны добавить репозиторий в файл sources.list, который находится в / etc / apt, поэтому самый быстрый способ - открыть терминал и написать:
sudo nano /etc/apt/sources.list
  1. Вводим пароль нашего пользователя.
  2. Теперь, в конце, мы добавим репозиторий и отметим его как надежный. В случае Pipewire и для Ubuntu 21.10, или 22.04, поскольку нет опции "jammy", мы бы добавили следующее:
deb [trusted=yes] http://ppa.launchpad.net/pipewire-debian/pipewire-upstream/ubuntu/ hirsute main
  1. После добавления вышеуказанного мы нажимаем Ctrl + O для сохранения, Enter для подтверждения и Ctrl + X для выхода.

Из того, что мы ввели, "[доверенный = да]" - вот что отмечает его как заслуживающий доверия, то идет URL-адрес репозитория, и "hirsute" будет обозначением версии, 21.10 в случае Ubuntu. Как мы уже объясняли, он также работает в Ubuntu 22.04, где выдает ошибку просто потому, что он еще не доступен для версии, которая будет выпущена в апреле следующего года.

И все. Это простой процесс это может избавить нас от многих головных болей, но мы не должны исключать возможность того, что это даст нам еще один. Лично я бы рекомендовал его только для программного обеспечения, которое нам нужно и которое недоступно другими способами, но этому есть объяснение.


Содержание статьи соответствует нашим принципам редакционная этика. Чтобы сообщить об ошибке, нажмите здесь.

Будьте первым, чтобы комментировать

Оставьте свой комментарий

Ваш электронный адрес не будет опубликован.

*

*

  1. Ответственный за данные: AB Internet Networks 2008 SL
  2. Назначение данных: контроль спама, управление комментариями.
  3. Легитимация: ваше согласие
  4. Передача данных: данные не будут переданы третьим лицам, кроме как по закону.
  5. Хранение данных: база данных, размещенная в Occentus Networks (ЕС)
  6. Права: в любое время вы можете ограничить, восстановить и удалить свою информацию.