В Ubuntu обнаружены новые уязвимости

Смокинг на зеленом фоне единиц и нулей

В системах Ubuntu обнаружен новый недостаток безопасности, на этот раз он связан с используемым ядром Linux, с помощью которого злоумышленники могут отказать в обслуживании и украсть конфиденциальную информацию.

Несколько дней назад мы опубликовали новость, в которой говорилось, чтои уязвимости были обнаружены en Операционные системы Ubuntu, потому что в эти дни был обнаружен еще один сбой безопасности, классифицированный как серьезный.

Ошибка безопасности на этот раз представляет собой уязвимость в ядре Linux следующих версий Ubuntu: Ubuntu 14.04 LTS Trusty Tahr и Ubuntu 15.04 Vivid Velvet. В каждой версии было ровно две ошибки, и они были обнаружены пользователями. К счастью, они уже исправлены, поэтому необходимо обновить

В версии 14.04 ошибки были обнаружены пару дней назад и заключались в следующем.

  • Пользователь Бенджамин Рандаццо обнаружил, что локальный пользователь может повысить привилегии и украсть личную информацию через ядро ​​из-за сбоя в мультисистемном контроллере.
  • Марк-Андре Люро обнаружил, что ядро ​​Linux этой версии Я не зарезервировал и не ограничил место который может занимать файл, в котором сохранен реестр, то системная служба может быть заблокирована с помощью DoS-атаки на этот файл.

В версии 15.04 они были обнаружены несколько часов назад, Они очень похожи на те, что предлагаются в версии 14.04. и они были обнаружены одними и теми же пользователями.

  • Бенджамин Рандаццо обнаружил утечка информации в ядре Из-за отказа мультисистемного драйвера ядра Linux, благодаря этому пользователь может украсть личную информацию.
  • Марк-Андре Люро обнаружил, что та же неудача что он обнаружил в версии 14.04, LTS также создавалась здесь, то есть для файла журнала не было зарезервировано места, поэтому можно было сделать отказ в обслуживании.

Конечно, эти уязвимости влияет на все версии Ubuntu, будь то Ubuntu, Lubuntu, Edubuntu, Xubuntu ... и мы должны немедленно обновить его для большей безопасности.

Для этого войдем в командную консоль и наберем классическую команду sudo apt-get-update и sudo apt-get upgradeТаким образом мы будем защищены от злоумышленников.

 


Содержание статьи соответствует нашим принципам редакционная этика. Чтобы сообщить об ошибке, нажмите здесь.

15 комментариев, оставьте свой

Оставьте свой комментарий

Ваш электронный адрес не будет опубликован.

*

*

  1. Ответственный за данные: AB Internet Networks 2008 SL
  2. Назначение данных: контроль спама, управление комментариями.
  3. Легитимация: ваше согласие
  4. Передача данных: данные не будут переданы третьим лицам, кроме как по закону.
  5. Хранение данных: база данных, размещенная в Occentus Networks (ЕС)
  6. Права: в любое время вы можете ограничить, восстановить и удалить свою информацию.

  1.   Хьюго сказал

    Эта ошибка влияет только на район Ubuntu? или это все как (Fedora, Debian, OpenSuse, RedHat и т. д.)

    1.    Амир Торрес (@amirtorrez) сказал

      apt-get upgrade предназначен для обновления приложений и системы (без изменения дистрибутива), apt-get dist-upgrade предназначен для обновления (изменения) дистрибутива, если у вас 14.04, при использовании dist-upgrade он обновится до 14.10, если вы хотите обновить до 15.04, вы должны использовать dist-upgrade в 14.04 и 14.10.

      1.    азпе сказал

        Технический глюк, ха-ха, сейчас меняю.
        привет

      2.    Ксавье сказал

        Это не совсем то, что вы упомянули. Команда apt-get dist-upgrade обновляет только ядро. Например, если у нас есть ядро ​​Linux 3.16.50, будет обновлено 3.16.51. Если версия дистрибутива на Ubuntu 14.04 после указанной команды все равно будет Ubuntu 14.04. Я не использую автоматические обновления, но всегда обновляюсь с терминала (sudo apt-get update и sudo apt-get upgrade и sudo apt-get dist-upgrade).

        привет

    2.    азпе сказал

      Только Ubuntu, но со всеми его переменными (Ubuntu Mate, Xubuntu ...)
      привет

  2.   Марио Перес сказал

    Я немного новичок в этом, но команда, которая подходит к концу, заключается не в обновлении дистрибутива, например с 14.04 по 15.04, что, если я хочу быть защищенным, но я не хочу обновлять версию?

    привет

  3.   Фернан сказал

    Привет
    Если это sudo apt-get upgrade, то с помощью dist-upgrade необходимо загрузить версию дистрибутива.
    Привет.

  4.   Хесус Карпио сказал

    Где теперь твой Бог ... Я пользуюсь Linux уже 15 лет и большую часть времени хвастаюсь тем, что у меня "безопасная" система. Безопасной ОС не существует, я думаю, что окна небезопасны, потому что они более привлекательны для хакеров. Чтобы найти его уязвимости, поскольку все больше людей используют его, теперь, когда Linux сделал важный шаг, мы начнем обнаруживать все более и более серьезные ошибки.

    1.    азпе сказал

      Но давайте не будем сравнивать, разница в том, что ошибки Linux исправлены, а Windows скрыта, ха-ха.
      привет

  5.   ЗеркалоСиний сказал

    Мой бог на небесах.
    Мне надоело занимать окна из-за большого количества синего экрана, ошибка за ошибкой :(
    Неполные обновления приводят к сбою того, что когда-то "работало"
    Расходы и затраты на покупку антивируса и лицензий для выполнения моих задач и работы.
    Теперь GNU / Linux является настоящим и захватил взгляды тех недоверчивых, кто не верил в это, так что теперь они съедают свои горькие слова и свою гордость от необходимости использовать его, копируя его, делая из этого район (хахахахаха), чтобы продолжить существовать и не оставаться в прошлом.
    Нет ничего идеального, но мало-помалу мы отбрасываем те вещи, которые нам не служат, и они остаются позади.
    Приветствую всех Linuxeros от души !!!!!
    И поздравляем создателей этого блога.

  6.   Ксавье сказал

    Кстати, надеюсь, ты мне поможешь. Выполняю обновления со вчерашнего дня, но возникла проблема с обновлением ядра. При обновлении выдает мне следующее:

    iemex @ iemex-AM1MHP: ~ $ sudo apt-get upgrade
    Чтение списка пакетов ... Готово
    Создание дерева зависимостей
    Чтение информации о статусе ... Готово
    Расчет обновления ... Готово
    0 обновлен, 0 будет установлен, 0 - удален, 0 - не обновлен.
    6 не полностью установлен или удален.
    После этой операции будет использовано 0Б дополнительного дискового пространства.
    Вы хотите продолжить? [Д / Н] да
    Настройка linux-image-extra-3.16.0-50-generic (3.16.0-50.66 ~ 14.04.1) ...
    run-parts: выполнение /etc/kernel/postinst.d/apt-auto-removal 3.16.0-50-generic /boot/vmlinuz-3.16.0-50-generic
    run-parts: выполнение /etc/kernel/postinst.d/dkms 3.16.0-50-generic /boot/vmlinuz-3.16.0-50-generic
    run-parts: выполнение /etc/kernel/postinst.d/initramfs-tools 3.16.0-50-generic /boot/vmlinuz-3.16.0-50-generic
    update-initramfs: Создание /boot/initrd.img-3.16.0-50-generic

    gzip: stdout: на устройстве не осталось места
    E: сбой mkinitramfs cpio 141 gzip 1
    update-initramfs: сбой для /boot/initrd.img-3.16.0-50-generic с 1.
    run-parts: /etc/kernel/postinst.d/initramfs-tools завершился с кодом возврата 1
    dpkg: пакет обработки ошибок linux-image-extra-3.16.0-50-generic (–configure):
    поток установил сценарий после установки вернул код выхода ошибки 1
    dpkg: проблемы с зависимостями, предотвращающие конфигурацию linux-image-generic-lts-utopic:
    linux-image-generic-lts-utopic зависит от linux-image-extra-3.16.0-50-generic; Тем не мение:
    Пакет `linux-image-extra-3.16.0-50-generic 'еще не настроен.

    dpkg: пакет обработки ошибок linux-image-generic-lts-utopic (–configure):
    проблемы с зависимостями - оставлено ненастроенным
    dpkg: проблемы с зависимостями предотвращают конфигурацию linux-generic-lts-utopic:
    linux-generic-lts-utopic зависит от linux-image-generic-lts-utopic (= 3.16.0.50.41); Тем не мение:
    Пакет `linux-image-generic-lts-utopic 'еще не настроен.

    dpkg: пакет обработки ошибок linux-generic-lts-utopic (–configure):
    проблемы с зависимостями - оставлено ненастроенным
    dpkg: проблемы с зависимостями не позволяют настроить linux-signed-image-3.16.0-50-generic:
    linux-signed-image-3.16.0-50-generic зависит от linux-image-extra-3.16.0-50-generic (= 3.16.0-50.66 ~ 14.04.1); однако отчет «аппорт» не был написан, потому что сообщение об ошибке указывает, что это сообщение об ошибке, связанное с предыдущей ошибкой.
    Отчет «аппорт» не был написан, потому что сообщение об ошибке указывает, что это сообщение об ошибке, связанное с предыдущей ошибкой.
    Отчет "аппорт" не был написан, потому что значение "MaxReports" уже достигнуто.
    Отчет "аппорт" не был написан, потому что значение "MaxReports" уже достигнуто.
    Отчет "аппорт" не был написан, потому что значение "MaxReports" уже достигнуто.
    o:
    Пакет `linux-image-extra-3.16.0-50-generic 'еще не настроен.

    dpkg: пакет обработки ошибок linux-signed-image-3.16.0-50-generic (–configure):
    проблемы с зависимостями - оставлено ненастроенным
    dpkg: проблемы с зависимостями не позволяют настроить linux-signed-image-generic-lts-utopic:
    linux-signed-image-generic-lts-utopic зависит от linux-signed-image-3.16.0-50-generic; Тем не мение:
    Пакет `linux-signed-image-3.16.0-50-generic 'еще не настроен.

    dpkg: пакет обработки ошибок linux-signed-image-generic-lts-utopic (–configure):
    проблемы с зависимостями - оставлено ненастроенным
    dpkg: проблемы с зависимостями не позволяют настроить linux-signed-generic-lts-utopic:
    linux-signed-generic-lts-utopic зависит от linux-signed-image-generic-lts-utopic (= 3.16.0.50.41); Тем не мение:
    Пакет `linux-signed-image-generic-lts-utopic 'еще не настроен.

    dpkg: пакет обработки ошибок linux-signed-generic-lts-utopic (–configure):
    проблемы с зависимостями - оставлено ненастроенным
    При обработке обнаружены ошибки:
    Linux-изображение-экстра-3.16.0-50-общий
    linux-image-generic-lts-utopic
    linux-generic-lts-utopic
    Linux-подписанный-образ-3.16.0-50-общий
    Linux-подписанный образ-generic-lts-utopic
    Linux-подписанный-generic-lts-utopic
    E: Sub-процессов / USR / бен / dpkg возвращает код ошибки (1)
    iemex @ iemex-AM1MHP: ~ $

    У меня Ubuntu 14.04.2 LTS AMD64. Я действительно не знаю, что делать, я не знаю, можно ли это исправить в следующем обновлении ядра, которое отправит Canonical или что-то в этом роде. Если кто-то может мне посоветовать, я буду признателен, потому что у меня мало времени на использование системы GNU / Linux.

  7.   Dhouard сказал

    Я не эксперт по Ubuntu, но похоже, что у вас закончилось место в разделе / ​​boot, где размещено ядро ​​(файл vmlinuz). Посмотрите, есть ли у вас несколько ядер в этом каталоге (вы будете различать их по номеру версии), и в случае коллеги я исправил это, удалив самое старое, а также initrd и другие файлы, связанные с его нумерацией (всякий раз, когда вы видите, что он повторяется).

    С другой стороны, я не знаю, будет ли в Ubuntu какой-либо инструмент для более безопасного удаления старых ядер.

    1.    Ксавье сказал

      Большое спасибо.

      На самом деле это недавно установленный Ubuntu (одна неделя), и у меня было только одно обновление ядра. Удаляю старые ядра через Ubuntu Tweak. Однако я не удалил старое ядро ​​из того, что я комментирую. Так что мои сомнения. На других компьютерах у меня было до 4 старых ядер, и со мной этого никогда не случалось.

  8.   христиане сказал

    Привет, Хавьер, у меня такая же проблема, и я не могу ее решить. Вы уже ее решили? Спасибо

    1.    Ксавье сказал

      Ну, как сказал Дуард, в / boot нет места, но я думаю, это потому, что на компьютере, который я установил, он создал загрузочный сектор EFI, возможно, это также ваш случай, потому что он оставляет небольшое пространство, как рекомендовано (не более чем 40 кб). Решение: просто удалите старое ядро. Я использовал Ubuntu Tweak, и когда он удалял старое ядро, он устанавливает компонент, который не смог установить, и проблема устранена.

      привет

bool (истина)