Расширения Firefox больше не могут использоваться из-за недействительного сертификата

Firefox без расширения

По состоянию на 0 часов (UTC) 4 мая у Mozilla возникла большая проблема. и именно с той минуты, в которую я меняю часы, Плагины Mozilla были автоматически отключены и вообще для всех пользователей браузера.

Это была большая проблема. чего люди Mozilla не ожидали, поскольку в этот день в то время должно было быть произведено автоматическое обновление сертификата который используется для генерации цифровых подписей в надстройках браузера.

Эта простая рутинная работа, которая «должна была создаваться автоматически», стала большим сюрпризом для Пользователи браузера Firefox, которые начали замечать, что расширения (или аксессуары) их больше нельзя использовать потому что они считаются устаревшими "по причине проблемы с сертификатом"

Эта проблема с недопустимым сертификатом повлияла на работу новых или существующих расширений, а также на установку расширений.

С этим на ходу отчеты быстро заполонили сеть, вызывая проблему, которая спонтанно отключила все расширения Firefox.

Каждое расширение теперь отображается как расширение с предупреждением о том, что «его использование не может быть проверено в Firefox и было отключено».

Mozilla подтвердила проблему

Столкнулся с серьезными жалобами от пользователей Mozilla проверила проблему и поняла это и через сообщение в Твиттере он извинился:

«Приносим извинения за проблемы, которые возникли с дополнениями прямо сейчас! Мы прилагаем все усилия, чтобы исправить это и держать вас в курсе ".

Firefox-твит

Кейтлин Нейман написала об этом в блоге фонда:

«Около 6:10 утра по тихоокеанскому времени мы получили отчет о проблеме с сертификатом для Firefox, из-за которой плагины закрылись ...

Наша команда активно работает над решением. Мы обновим его, как только у нас появится дополнительная информация.

Согласно отчету об ошибке bugzilla:

Срок действия промежуточного сертификата подписи, используемого для подписи подключаемых модулей Mozilla, истек 05 в полночь по всемирному координированному времени.

При условии Плагины Mozilla должны быть подписаны, прежде чем их можно будет использовать в Firefox., как только устройство, на котором запущен браузер, достигнет этого времени, браузер автоматически отключит их.

Очевидно, поскольку проблема связана с базовым сертификатом, переустановка расширений не сработает.

Если вы попытаетесь, вы, вероятно, получите другое сообщение об ошибке. Следует отметить, что вы можете устанавливать плагины, но не другие. Это может быть связано с тем, что надстройки были подписаны другим сертификатом, срок действия которого еще не истек.

Одно из сообщений в этом отчете об ошибке исходит от Кевина Броснана, старшего инженера по обеспечению качества в Mozilla, который сказал, что знает об этом и просматривает его.

И еще одно сообщение, на этот раз от Крис Маглионе объясняет, что степень этой ошибки известна:

«Затронуты все пользователи с плагинами и удаленными системными часами, за возможным исключением пользователей. Ночные выпуски / выпуски для разработчиков с отключенной подписью »

Как заставить ваши плагины снова работать?

Если надстройки не так важны, вы можете подождать, пока Mozilla решит проблему, и ваши надстройки снова начнут работать.

Для тех, кто не хочет ждать и хочет сразу активировать установленные расширения, у вас есть несколько вариантов:

Метод 1: поверните часы на несколько дней назад

Самый простой способ - перевести часы на несколько дней назад так что сертификат не может истечь.

Это будет работать, но это также будет означать, что любой сайт, к которому вы обращаетесь с истекшим сертификатом сегодня, тоже будет работать.

У ваших писем от локального почтового клиента будет неправильная дата, и некоторые сайты с https могут указывать на ошибки в своих сертификатах.

Метод 2: установите Firefox Nightly или версии для разработчиков

Другой вариант - установить версию Firefox для разработчиков или Nightly, которая отключает обязательную подпись для расширений.

Для этого из версий Developer или Nightly вы можете перейти: конфиг и поиск xpinstall.signatures.required. После того, как вы установили параметр, вам нужно изменить настройку на False, дважды щелкнув по нему.


Содержание статьи соответствует нашим принципам редакционная этика. Чтобы сообщить об ошибке, нажмите здесь.

6 комментариев, оставьте свой

Оставьте свой комментарий

Ваш электронный адрес не будет опубликован.

*

*

  1. Ответственный за данные: AB Internet Networks 2008 SL
  2. Назначение данных: контроль спама, управление комментариями.
  3. Легитимация: ваше согласие
  4. Передача данных: данные не будут переданы третьим лицам, кроме как по закону.
  5. Хранение данных: база данных, размещенная в Occentus Networks (ЕС)
  6. Права: в любое время вы можете ограничить, восстановить и удалить свою информацию.

  1.   Ева Мария Лоренцо сказал

    Так есть ли шанс, что twitter будет сброшен с Firefox в ближайшее время?

  2.   Хуан Карлос сказал

    Я очень испугалась, когда исчезли мои аксессуары, и не знала почему. Однако на рассвете в субботу все нормально.

  3.   Мигель сказал

    У меня не было проблем с расширениями

  4.   Диего-Гарсия сказал

    Я решил эту проблему с помощью сайта omicrono:

    Чтобы активировать их, мы должны открыть меню Firefox и ввести «Параметры» и «Конфиденциальность и безопасность». В разделе «Сбор и использование данных Firefox» мы должны убедиться, что опция «Разрешить Firefox устанавливать и запускать исследования» активирована.

    После активации патч устанавливается автоматически, поэтому нам не нужно ничего делать, просто подождите. Через некоторое время мы увидим, что расширения активируются сами. Когда это произойдет, мы можем снова отключить опцию исследования.

  5.   Тамбе сказал

    Ну, у меня закончились пароли, это серьезно, какое совпадение, что в то же время, когда они отменяют наши аксессуары, они предлагают нам некоторые заменители, которые их интересуют, верно? Что ж, с самого начала проекта я набирал подписчиков и сотрудничал, но пока и даже лучшие новости: прощай, Mozilla, удаление!

    1.    qtrit сказал

      Видите ли, вы видите запуск для установки Chrome или кого-то еще, вы увидите, что смеется xD

bool (истина)