Cara memasang Kurungan pada Debian / Ubuntu dan derivatif

Kurungan

Kurungan adalah penyunting kod yang boleh kita perolehi untuk edaran Gnu / Linux kami secara percuma. Kurungan Ia dicipta oleh syarikat Adobe walaupun ia adalah Perisian Percuma.

Kurungan bukan penyunting kod untuk digunakan kerana hanya membenarkan edit fail berkaitan pembangunan webWalaupun fail dari bahasa pengaturcaraan seperti C atau Java juga dapat dibuat dengan editor ini, ia tidak akan mempunyai fitur yang sama seperti ketika kita membuat file php atau javascript.

Kurungan menyokong plugin dan add-on yang memungkinkan untuk memperluas fungsi dan alatnya tetapi yang paling menarik adalah paparan langsung yang ditawarkannya. Fungsi ini membolehkan kita melihat perkembangan web yang sedang kita edit. Ini adalah salah satu fungsi yang paling saya sukai mengenai penyunting ini dan menjadikan saya memilihnya sebelum penyunting kod lain seperti Atom atau Teks Sublime.

Kurungan mempunyai fungsi pandangan langsung yang akan membantu kami mengembangkan projek web kami

Bracket versi terbaru boleh dipasang di edaran berasaskan Debian kami, untuk ini kami hanya perlu pergi laman web rasmi dan muat turun pakej deb yang sesuai dengan platform kami. Tetapi dalam beberapa pengedaran seperti Ubuntu, kaedah pemasangan ini boleh menyusahkan Kurungan memerlukan perpustakaan libgcrypt11 dan Ubuntu tidak memilikinya dalam versi terbarunya.

Untuk menyelesaikan masalah ini, kita memasang perpustakaan secara bebas atau kami menggunakan repositori standard yang menyelesaikan masalah ini. Secara peribadi, saya memilih yang terakhir dan untuk repositori webupd8, repositori yang memenuhi semua keperluan kami. Oleh itu, kami membuka terminal dan menulis perkara berikut:

sudo add-apt-repository ppa:webupd8team/brackets
sudo apt update
sudo apt install brackets

Dengan ini, editor Kurungan akan dipasang dan setelah beberapa minit pemasangan kita akan siap menggunakannya dan membuat aplikasi web kita, bukan?

DIKEMASKINI: Adobe berhenti membangunkan Brackets selepas perjanjian dengan Microsoft pada 1 September 2021, dan sejak itu tiada versi dikemas kini untuk Linux. Ya, kita boleh memasang apa yang dijelaskan di sini (v1.13), pakej Ketapkan (v1.11) dan Flatpak (v1.14.1). Maklumat lanjut, di sini.

Kandungan artikel mematuhi prinsip kami etika editorial. Untuk melaporkan ralat, klik di sini.

6 komen, tinggalkan komen anda

Tinggalkan komen anda

Alamat email anda tidak akan disiarkan. Ruangan yang diperlukan ditanda dengan *

*

*

  1. Bertanggungjawab untuk data: AB Internet Networks 2008 SL
  2. Tujuan data: Mengendalikan SPAM, pengurusan komen.
  3. Perundangan: Persetujuan anda
  4. Komunikasi data: Data tidak akan disampaikan kepada pihak ketiga kecuali dengan kewajiban hukum.
  5. Penyimpanan data: Pangkalan data yang dihoskan oleh Occentus Networks (EU)
  6. Hak: Pada bila-bila masa anda boleh menghadkan, memulihkan dan menghapus maklumat anda.

  1.   angeluz kata

    Saudara yang baik, saya mendapat idea yang hebat untuk pesanan beli dan saya telah menggunakan atom sehingga sekarang tetapi saya teruja dengan idea untuk bekerja semula dengan alat seperti dreamweaver

  2.   inaki kata

    Saya telah membangun di Ubuntu untuk masa yang agak singkat. Pada masa ini saya menggunakan gerhana. Tetapi yang sangat saya rindukan adalah templat dreamweaver, bahawa dengan mengemas kini pautan dalam menu, ini dikemas kini dalam semua fail yang menggunakan templat itu. Adakah terdapat sesuatu yang serupa dalam kurungan atau idea atau editor lain?

  3.   ais kata

    mmm saya meninggalkan tutorial yang lebih lengkap di blog saya, sekiranya anda berminat, tanpa menambahkan ppa. Sekiranya anda berminat, beritahu kami xD

    1.    jesus kata

      tetapi kongsi blog anda, ini akan sangat membantu, saya terutamanya mencari editor yang mengendalikan pakej Java atau terikat dengan jdk 8 atau openJDK JRE.

      salam

  4.   Javier Garcia kata

    Aplikasi sumber terbuka yang ingin tahu (bukan sumber terbuka) yang memerlukan perpustakaan penyulitan yang usang, ada yang lebih terkini, libgcrypt1.

  5.   jose kata

    Saya tidak menemui pakej ...