डेबियन / उबंटू आणि डेरिव्हेटिव्ह्जवर कंस कसे स्थापित करावे

कंस

ब्रॅकेट्स एक कोड एडिटर आहे जो आपल्या Gnu / Linux वितरणासाठी विनामूल्य मिळवू शकतो. कंस हे अ‍ॅडोब कंपनीने विनामूल्य सॉफ्टवेअर असूनही तयार केले आहे.

कंस वापरण्यास कोड संपादक नाही कारण ते केवळ परवानगी देते वेब विकास संबंधित फायली संपादित करा, जरी या संपादकासह सी किंवा जावा यासारख्या प्रोग्रामिंग भाषांमधील फायली देखील तयार केल्या जाऊ शकतात परंतु आम्ही पीएचपी किंवा जावास्क्रिप्ट फायली तयार करतो तेव्हा त्यासारख्या वैशिष्ट्यांचा आनंद घेणार नाही.

कंस प्लगइन्स आणि अ‍ॅड-ऑन्सचे समर्थन करतात जे त्याचे कार्ये आणि साधने विस्तृत करण्यास परवानगी देतात परंतु सर्वात मनोरंजक गोष्ट म्हणजे ती लाइव्ह व्ह्यू देते जी ती ऑफर करते. हे कार्य आम्हाला संपादित करीत असलेला कोणताही वेब विकास पाहण्याची परवानगी देतो. मला या संपादकाबद्दल सर्वात जास्त आवडलेले कार्य आहे आणि इतर कोड संपादक जसे की omटम किंवा उदात्त मजकूराच्या आधी मला ते निवडण्यास मदत करते.

ब्रॅकेट्समध्ये लाइव्ह व्ह्यू फंक्शन असते जे आम्हाला आमच्या वेब प्रोजेक्टचा विकास करण्यास मदत करेल

आमच्या डेबियन-आधारित वितरणामध्ये कंसांची नवीनतम आवृत्ती स्थापित केली जाऊ शकते, यासाठी आपल्याला फक्त येथे जावे लागेल अधिकृत वेबसाइट आणि आमच्या प्लॅटफॉर्मशी संबंधित डेब पॅकेज डाउनलोड करा. परंतु उबंटूसारख्या काही वितरणामध्ये ही स्थापना पद्धत त्रासदायक असू शकते कंसात libgcrypt11 लायब्ररी आवश्यक आहे आणि उबंटूमध्ये ती नाही त्याच्या अगदी अलीकडील आवृत्त्यांमध्ये.

या समस्येचे निराकरण करण्यासाठी, आम्ही एकतर लायब्ररी स्वतंत्रपणे स्थापित करतो किंवा आम्ही एक मानक रेपॉजिटरी वापरतो जी ही समस्या सोडवते. मी वैयक्तिकरित्या नंतरच्या आणि वेबअपडी 8 रेपॉजिटरीची निवड करतो, आमच्या सर्व गरजा पूर्ण करणारे एक भांडार. तर आपण टर्मिनल उघडून पुढील गोष्टी लिहित आहोत.

sudo add-apt-repository ppa:webupd8team/brackets
sudo apt update
sudo apt install brackets

यासह, कंस संपादक स्थापित होईल आणि स्थापनेच्या कित्येक मिनिटांनंतर आमच्याकडे ते वापरण्यासाठी आणि वेब अनुप्रयोग तयार करण्यासाठी तयार असेल, नाही का?

अद्यतनित: Adobe ने 1 सप्टेंबर 2021 रोजी Microsoft सोबत केलेल्या करारानंतर ब्रॅकेट विकसित करणे थांबवले आणि तेव्हापासून Linux साठी कोणतीही अपडेट केलेली आवृत्ती नाही. होय आम्ही येथे (v1.13) जे स्पष्ट केले आहे ते पॅकेज स्थापित करू शकतो स्नॅप (v1.11) आणि द फ्लॅटपॅक (v1.14.1). अधिक माहिती, येथे.

लेखाची सामग्री आमच्या तत्त्वांचे पालन करते संपादकीय नीति. त्रुटी नोंदविण्यासाठी क्लिक करा येथे.

6 टिप्पण्या, आपल्या सोडा

आपली टिप्पणी द्या

आपला ई-मेल पत्ता प्रकाशित केला जाणार नाही. आवश्यक फील्ड चिन्हांकित केले आहेत *

*

*

  1. डेटासाठी जबाबदार: AB इंटरनेट नेटवर्क 2008 SL
  2. डेटाचा उद्देशः नियंत्रण स्पॅम, टिप्पणी व्यवस्थापन.
  3. कायदे: आपली संमती
  4. डेटा संप्रेषण: कायदेशीर बंधन वगळता डेटा तृतीय पक्षास कळविला जाणार नाही.
  5. डेटा संग्रहण: ओकेन्टस नेटवर्क (EU) द्वारा होस्ट केलेला डेटाबेस
  6. अधिकारः कोणत्याही वेळी आपण आपली माहिती मर्यादित, पुनर्प्राप्त आणि हटवू शकता.

  1.   अँजेलुझ म्हणाले

    उत्तम बंधू, मी बाय संदेशासाठी उदात्त कल्पना मिळविली आणि आतापर्यंत मी अणू वापरला आहे पण स्वप्नातील सारख्या उपकरणाने पुन्हा काम करण्याच्या कल्पनेने मी उत्सुक आहे

  2.   आयकाकी म्हणाले

    मी तुलनेने कमी काळासाठी उबंटूचा विकास करीत आहे. मी सध्या ग्रहण वापरतो. पण जे मी खरोखर गमावत आहे ते म्हणजे स्वप्नातील वीजेचे टेम्पलेट्स, की मेनूमधील दुवा अद्यतनित करून हे टेम्पलेट वापरणार्‍या सर्व फायलींमध्ये हे अद्यतनित केले जाते. कंसात किंवा इतर कोणत्याही आदर्श किंवा संपादकात असे काही आहे का?

  3.   बर्फ म्हणाले

    मिमीएम मी माझ्या ब्लॉगवर अधिक पूर्ण ट्यूटोरियल सोडले, जर आपल्याला आवड असेल तर पीपीए न जोडता. आपल्याला स्वारस्य असल्यास त्यांना एक्सडी कळवा

    1.    येशू म्हणाले

      परंतु आपला ब्लॉग सामायिक करा, हे खूप उपयुक्त ठरेल, मी विशेषतः जावा पॅकेजेस हाताळणारे किंवा जेडीके 8 किंवा ओपनजेडीके जेआरईशी जोडलेले संपादक शोधत आहे.

      कोट सह उत्तर द्या

  4.   जेव्हियर गार्सिया म्हणाले

    जिज्ञासू मुक्त स्रोत अनुप्रयोग (मुक्त स्त्रोत नाही) ज्यास अप्रचलित कूटबद्धीकरण लायब्ररीची आवश्यकता आहे, तेथे अधिक वर्तमान आहे, libgcrypt1.

  5.   जॉस म्हणाले

    मला हे पॅकेज सापडले नाही ...