Debian / Ubuntu және туындыларына кронштейндерді қалай орнатуға болады

кронштейндер

Кронштейндер - бұл Gnu / Linux таратылымы үшін ақысыз ала алатын код редакторы. кронштейндер Оны Adobe компаниясы жасайды, бірақ ол еркін бағдарламалық жасақтама.

Жақшалар кодтық редактор емес, өйткені ол тек рұқсат береді веб-дамуға қатысты файлдарды өңдеу, C немесе Java сияқты бағдарламалау тілдерінен файлдар осы редактормен жасалуы мүмкін, бірақ ол бізде php немесе javascript файлдарын құру сияқты мүмкіндіктерге ие болмайды.

Жақшалар оның функциялары мен құралдарын кеңейтуге мүмкіндік беретін плагиндер мен қондырмаларды қолдайды, бірақ ең қызықтысы - ол ұсынатын тірі көрініс. Бұл функция біз өңдеп жатқан кез-келген веб-дамуды көруге мүмкіндік береді. Бұл мен үшін ең жақсы көретін және Atom немесе Sublime Text сияқты басқа код редакторларынан бұрын таңдауыма мүмкіндік беретін функциялардың бірі.

Жақшаларда веб-жобаны дамытуға көмектесетін тірі қарау функциясы бар

Жақшалардың соңғы нұсқасын Debian негізіндегі дистрибутивке орнатуға болады, бұл үшін бізге бару керек ресми сайт және платформамызға сәйкес деб-пакетті жүктеп алыңыз. Бірақ Ubuntu сияқты кейбір таратылымдарда бұл орнату әдісі қиындық тудыруы мүмкін Жақшаға libgcrypt11 кітапханасы қажет, ал Ubuntu-да ол жоқ оның ең соңғы нұсқаларында.

Бұл мәселені шешу үшін біз кітапхананы өз бетінше орнатамыз немесе біз бұл мәселені шешетін стандартты репозиторийді қолданамыз. Мен өзім соңғысын және барлық талаптарға сай келетін репозиторийді - webupd8 репозиторийін таңдаймын. Сондықтан біз терминал ашып, келесіні жазамыз:

sudo add-apt-repository ppa:webupd8team/brackets
sudo apt update
sudo apt install brackets

Осы арқылы Brackets редакторы орнатылады және бірнеше минут орнатқаннан кейін біз оны қолдануға және веб-қосымшаларды жасауға дайын боламыз, солай емес пе?

ЖАҢАРТЫЛДЫ: Adobe 1 жылдың 2021 қыркүйегінде Microsoft корпорациясымен келісімге келгеннен кейін жақшаларды әзірлеуді тоқтатты, содан бері Linux үшін жаңартылған нұсқа жоқ. Иә, біз мұнда түсіндірілгенді (v1.13), буманы орната аламыз кезектен тыс (v1.11) және Тегістеуіш (v1.14.1). Көбірек ақпарат, Мұнда.

Мақаланың мазмұны біздің ұстанымдарымызды ұстанады редакторлық этика. Қате туралы хабарлау үшін нұқыңыз Мұнда.

6 пікір, өз пікіріңізді қалдырыңыз

Пікіріңізді қалдырыңыз

Сіздің электрондық пошта мекен-жайы емес жарияланады. Міндетті өрістер таңбаланған *

*

*

  1. Деректерге жауапты: AB Internet Networks 2008 SL
  2. Деректердің мақсаты: СПАМ-ны басқару, түсініктемелерді басқару.
  3. Заңдылық: Сіздің келісіміңіз
  4. Деректер туралы ақпарат: заңды міндеттемелерді қоспағанда, деректер үшінші тұлғаларға жіберілмейді.
  5. Деректерді сақтау: Occentus Networks (ЕО) орналастырған мәліметтер базасы
  6. Құқықтар: Сіз кез-келген уақытта ақпаратты шектей, қалпына келтіре және жоя аласыз.

  1.   Ангелуз дижо

    Керемет ағайын, мен сатып алу туралы хабарламаның керемет идеясын қабылдадым және осы уақытқа дейін атомды қолдандым, бірақ мен Dreamweaver сияқты құралмен қайтадан жұмыс істеу идеясына қуаныштымын.

  2.   инаки дижо

    Мен Ubuntu-де салыстырмалы түрде аз уақыт болды. Қазіргі уақытта мен күннің тұтылуын қолданамын. Бірақ Dreamweaver шаблондарын қатты сағынатыным - мәзірдегі сілтемені жаңарту арқылы бұл сол үлгіні қолданатын барлық файлдарда жаңартылады. Жақшаларда немесе басқа идеяларда немесе редакторларда ұқсас нәрсе бар ма?

  3.   мұз дижо

    mmm Мен блогымда толығырақ нұсқаулық қалдырдым, егер сізді қызықтыратын болса, ppa қоспай. Егер сізді қызықтырса, xD-ге хабарлаңыз

    1.    Иса дижо

      бірақ сіздің блогыңызбен бөлісіңіз, бұл өте пайдалы болар еді, мен әсіресе Java пакеттерін өңдейтін немесе jdk 8 немесе openJDK JRE-ге байланған редактор іздеймін.

      тілекпен

  4.   Хавьер Гарсия дижо

    Ескірген шифрлау кітапханасын қажет ететін ашық бастапқы кодты қосымша (ашық емес), қазіргі нұсқасы бар, libgcrypt1.

  5.   Хосе дижо

    Мен пакетті таба алмадым ...