Ha kedvenc kiegészítője leállt a Kodiban, valószínűleg azért, mert túl új Python-verziója van.

Kodi és Python

Hosszú idő telt el azóta Kodi ez nekünk, Linux-felhasználóknak több fejfájást okoz, mint örömet. Mióta felkerült Mátrix, vannak olyan kiegészítők, amelyek leálltak. néhány telepítve vannak, de a tartalmuk nem mutat semmit. Másoknál egyszerűen összeomlást okoz. Mi történik? A probléma nem a lejátszóval van, hanem a bővítményfejlesztőkkel és az általuk használt programozási nyelvvel.

Vannak olyan kiegészítők, amelyek a Python 3.10.0 és 3.10.4 közötti verziójának hibája miatt leálltak, és ezt a problémát a 3.10.5 verzió javította. Ez a probléma már megoldódott, de más kiegészítők nem működnek, mert fel vannak készítve a programozási nyelv régebbi verzióira. És mert csak linuxon sikertelen? Nos, nem vagyok benne biztos, hogy meghibásodik-e macOS-en, de Linuxon meghibásodik, mert a Python az operációs rendszer mellé van telepítve, és nincs beépítve a Kodiba, mint a Windows és az Android rendszeren.

A Kodi for Windows és Android a saját Python verzióját használja

A Kodi for Windows és Android saját verzióval rendelkezik Piton, és a használt Kodi verziójától függően változik. Ha leáll, az azért van, mert a kiegészítő fejlesztők "lefedik" a kódjukat (lezárják), hogy megakadályozzák mások lemásolását, és ez az álcázó szoftver, amely a kódot csak a Python egyik verziójával teszi kompatibilissé. Ezért ha egy kiegészítőt fejlesztenek a Python 3.8-hoz, a mi Linuxunkon pedig a Linux 3.10.x-hez, a Kodi nem "érti" az álcázott kódot, és leáll. Ennek nem szabadna megtörténnie, és úgy tűnik, nem is az álcázás nélkül, de érthető, hogy a fejlesztők inkább "lezárják" a szoftvereiket.

És mit tehetünk? Nos, a dolgok nem néznek ki túl jól. Ha egyszer megtörtént, akkor a jövőben is biztosan megtörténik, legalábbis ha a fejlesztők egy kicsit sem törődnek velünk, linuxosokkal, és már tudjuk, hogy ez általában nem így van. Ezek a fejlesztők „álcázzák” és csak az Android és Windows rendszerrel kompatibilis verziókat töltenek fel, a legújabb támogatott verzió pedig a Python 3.8. Ezért az egyik megoldás az, hogy a Kodi a Python azon verzióját használja, amely Ubuntu-alapú operációs rendszereken lehetséges.

A kiegészítők használatához meg kell nyitnia egy terminált, és be kell írnia a következőket:

sudo apt install software-properties-common sudo apt update -y && sudo apt upgrade -y sudo add-apt-repository ppa:deadsnakes/ppa sudo apt update -y && sudo apt upgrade -y sudo apt install python3.8* sudo apt patchelf telepítése sudo patchelf --replace-needed libpython3.10.so.1.0 libpython3.8.so.1.0 /usr/lib/x86_64-linux-gnu/kodi/kodi.bin

A fentiek telepítik a Python 3.8-at MELLETT a Python már meglévő verziója, és a Kodit úgy fogja javítani, hogy a 3.8-as verziót használja, és ne a 3.10.x-et, ami nem lenne kompatibilis néhány kiegészítővel.

Nem a legelegánsabb...

… és mindenkinek mérlegelnie kell, hogy megéri-e ezt a megoldást alkalmazni vagy sem. Ezt meg tudom erősíteni az Ubuntu 22.04-en működik, de nem a Manjaroban, mivel régen frissítettek 3.10-re, és az AUR 3.8-as verzióját nem sikerül lefordítani. Azt is megerősítették, hogy működik a Linux Mint 21-en, és az összes többi disztribúción attól függ, hogy az 1. Python 3.8 telepíthető-e; és 2, patchself telepíthető.

Másrészt figyelembe kell venni, hogy mit kell tenni ez megszakíthatja a kompatibilitást más kiegészítőkkel, de nem a legvalószínűbb. Amint már említettük, a fejlesztők leginkább az Androidra és a Windowsra koncentrálnak, így a Kodi által ezeken az operációs rendszereken használt Python egyik verziójának használata nem okozhat problémát. Mégis itt hagyjuk a figyelmeztetést.

Egy másik lehetőség, ha van hely a merevlemezen és elegendő erőforrással rendelkező számítógépünk van, ugyanezt megtesszük, de egy Ubuntu virtuális gépben. A Kodi komolyabb problémák nélkül fut Linux virtuális gépeken, szóval ez lehetséges. Nem is a legelegánsabb, de így is működik.

forrás: távíró.


Hagyja megjegyzését

E-mail címed nem kerül nyilvánosságra. Kötelező mezők vannak jelölve *

*

*

  1. Az adatokért felelős: AB Internet Networks 2008 SL
  2. Az adatok célja: A SPAM ellenőrzése, a megjegyzések kezelése.
  3. Legitimáció: Az Ön beleegyezése
  4. Az adatok közlése: Az adatokat csak jogi kötelezettség alapján továbbítjuk harmadik felekkel.
  5. Adattárolás: Az Occentus Networks (EU) által üzemeltetett adatbázis
  6. Jogok: Bármikor korlátozhatja, helyreállíthatja és törölheti adatait.

  1.   gazdag dijo

    köszönöm szépen, ez a megoldás aranyat ér, én személy szerint úgy gondolom, hogy ez még egy ok, amiért nem hagyom el a linux mintát – ubuntu, üdv