Nouvelles vulnérabilités détectées dans Ubuntu

Tux sur fond vert de uns et de zéros

Nouvelle faille de sécurité détectée dans les systèmes Ubuntu, cette fois, ils ont à voir avec le noyau Linux qu'ils utilisent et avec lequel les attaquants pourraient refuser le service et voler des informations privilégiées

Il y a quelques jours, nous avions publié un reportage dans lequel il était dit que set des vulnérabilités avaient été détectées en Systèmes d'exploitation Ubuntu, car ces jours-ci, une autre faille de sécurité classée comme grave a été détectée.

L'erreur de sécurité cette fois est une vulnérabilité dans le noyau Linux des versions suivantes d'Ubuntu: Ubuntu 14.04 LTS Trusty Tahr et Ubuntu 15.04 Vivid Velvet. Il y avait exactement deux bogues dans chaque version et ils ont été découverts par les utilisateurs. Heureusement, ils ont déjà été corrigés, rendant nécessaire la mise à jour

Dans la version 14.04, les bogues ont été découverts il y a quelques jours et ils étaient les suivants.

  • L'utilisateur Benjamin Randazzo a découvert qu'un utilisateur local pourrait augmenter les privilèges et voler des informations privées via le noyau en raison d'une défaillance du contrôleur multi-système.
  • Marc-André Lureau a découvert que le noyau Linux de cette version Je n'avais pas réservé ou limité l'espace qui peut occuper le fichier où le registre est enregistré, alors le service système pourrait être refusé avec une attaque DoS sur ce fichier.

En version 15.04, ils ont été découverts il y a quelques heures, Ils sont très similaires à ceux proposés par la version 14.04 et ils ont été découverts par les mêmes utilisateurs.

  • Benjamin Randazzo a détecté un fuite d'informations dans le noyau En raison de l'échec du pilote multisystème du noyau Linux, un utilisateur peut ainsi voler des informations privées.
  • Marc-André Lureau a découvert que le même échec qu'il a découvert dans la version 14.04 LTS a également été produit ici, c'est-à-dire qu'aucun espace n'a été réservé pour le fichier journal, donc un déni de service a pu être fait.

Bien sûr, ces vulnérabilités affectent toutes les versions d'Ubuntu, qu'il s'agisse d'Ubuntu, Lubuntu, Edubuntu, Xubuntu ... et nous devons mettre à jour immédiatement pour plus de sécurité.

Pour ce faire, nous allons accéder à la console de commande et taper la commande classique sudo apt-get-update et sudo apt-get mise à jourDe cette façon, nous serons déjà à l'abri des attaquants.

 


Le contenu de l'article adhère à nos principes de éthique éditoriale. Pour signaler une erreur, cliquez sur c'est par ici !.

15 commentaires, laissez le vôtre

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée.

*

*

  1. Responsable des données : AB Internet Networks 2008 SL
  2. Finalité des données: Contrôle du SPAM, gestion des commentaires.
  3. Légitimation: votre consentement
  4. Communication des données: Les données ne seront pas communiquées à des tiers sauf obligation légale.
  5. Stockage des données: base de données hébergée par Occentus Networks (EU)
  6. Droits: à tout moment, vous pouvez limiter, récupérer et supprimer vos informations.

  1.   Hugo dit

    Ce bogue affecte-t-il uniquement le quartier Ubuntu? ou est-ce tout comme (Fedora, Debian, OpenSuse, RedHat, etc ...)

    1.    Amir Torres (@amirtorrez) dit

      apt-get upgrade consiste à mettre à jour les applications et le système (sans changer la distribution), apt-get dist-upgrade consiste à mettre à jour (changer) la distribution, si vous avez 14.04, lors de l'utilisation de dist-upgrade, il sera mis à jour vers 14.10, si vous vous voulez mettre à jour vers 15.04, vous devez utiliser dist-upgrade en 14.04 et en 14.10.

      1.    azpe dit

        Problème technique haha, je le change maintenant.
        salutations

      2.    Xavier dit

        Ce n'est pas exactement ce que vous mentionnez. La commande apt-get dist-upgrade met uniquement à jour le noyau. Par exemple, si nous avons un noyau Linux 3.16.50, 3.16.51 sera mis à jour. Si la version de distribution sur Ubuntu 14.04 après la commande mentionnée, ce sera toujours Ubuntu 14.04. Je n'utilise pas de mises à jour automatiques, mais je mets toujours à jour depuis le terminal (sudo apt-get update & sudo apt-get upgrade & sudo apt-get dist-upgrade).

        salutations

    2.    azpe dit

      Ubuntu uniquement, mais dans toutes ses variables (Ubuntu Mate, Xubuntu ...)
      salutations

  2.   Mario Perez dit

    Je suis un peu nouveau dans ce domaine, mais la commande qui arrive à la fin n'est pas de mettre à jour la distribution, par exemple du 14.04 au 15.04, que faire si je veux être protégé mais que je ne veux pas mettre à jour la version ??.

    salutations

  3.   Fernan dit

    Salut
    S'il s'agit de sudo apt-get upgrade, avec dist-upgrade, il s'agit de télécharger la version de la distribution.
    Salutations.

  4.   Jésus Carpio dit

    Où est ton Dieu maintenant ... J'utilise Linux depuis 15 ans et la plupart du temps je me vante d'avoir un système "sûr". pour rechercher ses vulnérabilités, puisque de plus en plus de personnes l'utilisent, maintenant que linux a fait un saut important, nous allons commencer à découvrir des bogues de plus en plus sérieux.

    1.    azpe dit

      Maintenant, mais ne comparons pas, la différence est que les erreurs Linux sont corrigées et que Windows est caché haha.
      salutations

  5.   MiroirBleu dit

    Mon dieu est au paradis.
    Je me suis ennuyé d'occuper des fenêtres à cause de tant d'écran bleu, erreur après erreur :(
    Mises à jour incomplètes entraînant l'échec de ce qui a déjà "fonctionné"
    Frais et dépenses pour l'achat d'antivirus et de licences pour effectuer mes tâches et mon travail.
    Maintenant, GNU / Linux est le présent et a capturé les regards de ces incrédules qui n'y croyaient pas, alors maintenant ils mangent leurs mots amers et leur fierté de devoir l'utiliser, le copiant, en en faisant un quartier (hahahahaha) pour continuer subsister et ne pas rester dans le passé.
    Rien n'est parfait, mais petit à petit, nous abandonnons ces choses qui ne nous servent pas et elles sont laissées pour compte.
    Salutations à tous les Linuxeros du cœur !!!!!
    Et félicitations aux créateurs de ce blog.

  6.   Xavier dit

    Au fait, j'espère que vous pourrez m'aider. J'effectue les mises à jour depuis hier mais un problème est survenu avec la mise à jour du noyau. Lors de la mise à jour, il me lance ce qui suit:

    iemex @ iemex-AM1MHP: ~ $ sudo apt-get mise à jour
    Lecture de la liste des paquets ... Terminé
    Créer une arborescence de dépendances
    Lecture des informations d'état ... Terminé
    Calcul de la mise à jour ... Terminé
    0 mis à jour, 0 sera installé, 0 à supprimer et 0 non mis à jour.
    6 pas entièrement installé ou retiré.
    0 Go d'espace disque supplémentaire sera utilisé après cette opération.
    souhaitez-vous continuer? [O / n] oui
    Configuration de linux-image-extra-3.16.0-50-generic (3.16.0-50.66 ~ 14.04.1) ...
    run-parts: exécution de /etc/kernel/postinst.d/apt-auto-removal 3.16.0-50-generic /boot/vmlinuz-3.16.0-50-generic
    run-parts: exécution de /etc/kernel/postinst.d/dkms 3.16.0-50-generic /boot/vmlinuz-3.16.0-50-generic
    run-parts: exécution de /etc/kernel/postinst.d/initramfs-tools 3.16.0-50-generic /boot/vmlinuz-3.16.0-50-generic
    update-initramfs: Génération de /boot/initrd.img-3.16.0-50-generic

    gzip: stdout: Il ne reste plus d'espace sur l'appareil
    E: échec de mkinitramfs cpio 141 gzip 1
    update-initramfs: échec pour /boot/initrd.img-3.16.0-50-generic avec 1.
    run-parts: /etc/kernel/postinst.d/initramfs-tools quitté avec le code de retour 1
    dpkg: package de traitement d'erreur linux-image-extra-3.16.0-50-generic (–configure):
    le thread a installé le script de post-installation a renvoyé le code de sortie d'erreur 1
    dpkg: problèmes de dépendance empêchant la configuration linux-image-generic-lts-utopic:
    linux-image-generic-lts-utopic dépend de linux-image-extra-3.16.0-50-generic; cependant:
    Le paquet `linux-image-extra-3.16.0-50-generic 'n'est pas encore configuré.

    dpkg: package de traitement d'erreur linux-image-generic-lts-utopic (–configure):
    problèmes de dépendance - non configurés
    dpkg: les problèmes de dépendance empêchent la configuration linux-generic-lts-utopic:
    linux-generic-lts-utopic dépend de linux-image-generic-lts-utopic (= 3.16.0.50.41); cependant:
    Le paquet `linux-image-generic-lts-utopic 'n'est pas encore configuré.

    dpkg: erreur de traitement du package linux-generic-lts-utopic (–configure):
    problèmes de dépendance - non configurés
    dpkg: les problèmes de dépendance empêchent la configuration de linux-signed-image-3.16.0-50-generic:
    linux-signed-image-3.16.0-50-generic dépend de linux-image-extra-3.16.0-50-generic (= 3.16.0-50.66 ~ 14.04.1); Cependant, un rapport "apport" n'a pas été écrit car le message d'erreur indique qu'il s'agit d'un message d'erreur associé à un échec précédent.
    Un rapport «apport» n'a pas été rédigé car le message d'erreur indique qu'il s'agit d'un message d'erreur associé à un échec précédent.
    Aucun rapport "apport" n'a été rédigé car la valeur de "MaxReports" a déjà été atteinte
    Aucun rapport "apport" n'a été rédigé car la valeur de "MaxReports" a déjà été atteinte
    Aucun rapport "apport" n'a été rédigé car la valeur de "MaxReports" a déjà été atteinte
    o:
    Le paquet `linux-image-extra-3.16.0-50-generic 'n'est pas encore configuré.

    dpkg: package de traitement d'erreur linux-signed-image-3.16.0-50-generic (–configure):
    problèmes de dépendance - non configurés
    dpkg: les problèmes de dépendance empêchent la configuration de linux-signed-image-generic-lts-utopic:
    linux-signed-image-generic-lts-utopic dépend de linux-signed-image-3.16.0-50-generic; cependant:
    Le paquet `linux-signed-image-3.16.0-50-generic 'n'est pas encore configuré.

    dpkg: package de traitement d'erreur linux-signed-image-generic-lts-utopic (–configure):
    problèmes de dépendance - non configurés
    dpkg: les problèmes de dépendance empêchent la configuration de linux-signed-generic-lts-utopic:
    linux-signed-generic-lts-utopic dépend de linux-signed-image-generic-lts-utopic (= 3.16.0.50.41); cependant:
    Le paquet `linux-signed-image-generic-lts-utopic 'n'est pas encore configuré.

    dpkg: erreur de traitement du package linux-signed-generic-lts-utopic (–configure):
    problèmes de dépendance - non configurés
    Des erreurs ont été rencontrées lors du traitement:
    linux-image-extra-3.16.0-50-générique
    linux-image-générique-lts-utopique
    linux-générique-lts-utopique
    linux-signed-image-3.16.0-50-generic
    image-signée-linux-générique-lts-utopic
    linux-signé-générique-lts-utopic
    E: Sub-process / usr / bin / dpkg a retourné un code d'erreur (1)
    iemex @ iemex-AM1MHP: ~ $

    Mon Ubuntu est 14.04.2 LTS AMD64. La vérité est que je ne sais pas quoi faire, je ne sais pas si cela peut être corrigé dans la prochaine mise à jour du noyau envoyée par Canonical ou quoi. Si quelqu'un peut me conseiller, je l'apprécierai car je n'ai pas beaucoup de temps à utiliser un système GNU / Linux.

  7.   Dhouard dit

    Je ne suis pas un expert Ubuntu mais vous semblez manquer d'espace sur la partition / boot, où le noyau (le fichier vmlinuz) est hébergé. Regardez si vous avez plusieurs noyaux dans ce répertoire (vous les différencierez par le numéro de version) et, dans le cas d'un collègue, je l'ai corrigé en supprimant le plus ancien, ainsi que l'initrd et d'autres les fichiers qui lui sont associés numérotation (tant que vous voyez qu'il est répété).

    D'un autre côté, je ne sais pas s'il y aura un outil dans Ubuntu pour supprimer les anciens noyaux de manière plus sécurisée.

    1.    Xavier dit

      Merci beaucoup.

      En fait, il s'agit d'un Ubuntu fraîchement installé (une semaine) et je n'ai eu qu'une seule mise à jour du noyau. Je supprime les anciens noyaux via Ubuntu Tweak. Cependant, je n'ai pas supprimé l'ancien noyau de ce que je commente. Alors mon doute. Dans d'autres ordinateurs, j'ai eu jusqu'à 4 vieux noyaux et cela ne m'est jamais arrivé.

  8.   Noëls dit

    Salut Javier, j'ai le même problème et je ne peux pas le résoudre, l'avez-vous déjà résolu? Merci

    1.    Xavier dit

      Eh bien, comme l'a dit dhouard, il n'y a pas d'espace dans / boot, mais je pense que c'est parce que dans l'ordinateur que je l'ai installé, j'ai créé un secteur de démarrage EFI, peut-être que c'est votre cas aussi car il laisse un petit espace comme recommandé (pas plus de 40 ko). Solution: supprimez simplement l'ancien noyau. J'ai utilisé Ubuntu Tweak et pour le moment, il supprime l'ancien noyau, il installe le composant qu'il n'a pas pu installer et le problème est résolu.

      salutations