La nouvelle version de Dart 2.12 est déjà sortie et arrive avec Null Safety et FFI

Suivi du précédent sortie de la nouvelle version de Flutter 2, Google a également publié le message (presque en même temps) du lancement de la nouvelle version langage de programmation Fléchette 2.12, dans lequel le développement de la branche Dart 2 radicalement repensée se poursuit.

Pour ceux qui ne connaissent pas Dart (initialement appelé Dash), sachez qu'il s'agit d'un langage de programmation open source, développé par Google.

À propos de Dart

Dard est conçu pour offrir de meilleurs résultats grâce à des alternatives à certains problèmes de JavaScript, bien que dans sa présentation aucune référence explicite n'ait été faite JavaScript. Il se veut un outil simple pour des projets plus importants et pour offrir une meilleure sécurité.

Le but de Dart n'est pas de remplacer JavaScript comme principal langage de programmation Web dans les navigateurs Web, mais pour offrir une alternative plus moderne. L'esprit du langage se reflète dans les déclarations de Lars Bak, ingénieur logiciel de Google, qui définit Dart comme un "langage structuré mais flexible pour la programmation Web".

Parmi les caractéristiques uniques Dart met en évidence ce qui suit:

  • Portable: les des compilateurs efficaces génèrent du code machine x86 et ARM pour les appareils et JavaScript optimisé pour le Web. Un large éventail de cibles est pris en charge: appareils mobiles, ordinateurs de bureau, backends d'applications, etc. Un ensemble complet de bibliothèques et de packages fournit des API cohérentes qui fonctionnent sur toutes les plates-formes, ce qui réduit encore le coût de création de véritables applications multiplateformes.
  • Productif: la plate-forme de fléchettes permet un développement rapide et itératif à la fois pour les appareils natifs et pour le Web. Et Dart propose des constructions riches telles que les isolats et async / await pour gérer les modèles courants d'applications simultanées et basées sur les événements.
  • Solide: Le système null-safe de Dart détecte les erreurs pendant le développement. Oui la plate-forme globale est hautement évolutive et fiable, avec une utilisation en production depuis plus d'une décennie par un large éventail d'applications, y compris des applications critiques pour l'entreprise telles que Google Ads et Google Assistant.

Quoi de neuf dans Dart 2.12?

Cette version se distingue par la stabilisation du mode de sécurité "Null" (Null Safety), qui évitera les plantages causés par les tentatives d'utilisation de variables dont la valeur n'est pas définie et définie sur "Null" car cela permettra aux développeurs de détecter plus facilement les erreurs nulles lors du développement. Auparavant, il était difficile de faire la distinction entre le code qui prévoyait de passer comme nul et le code qui ne fonctionnait pas avec des valeurs nulles.

C'est-à- implique que les variables ne peuvent pas avoir de valeurs nulles à moins qu'elles ne soient affectées explicitement une valeur nulle. Le mode considère strictement les types de variables, permettant au compilateur d'appliquer des optimisations supplémentaires. La conformité de type est vérifiée au moment de la compilation, par exemple, tenter d'attribuer une valeur "Null" à une variable avec un type qui n'implique pas un état indéfini, tel que "int", générera une erreur. Null Safety est un changement majeur dans la langue et nécessite quelques modifications lors du codage.

Une autre amélioration majeure de Dart 2.12 est l'implémentation stable de la bibliothèque FFI , qui vous permet de créer du code haute performance à partir de laquelle vous pouvez accéder aux API C, car FFI permet de passer des structures par des valeurs et pas seulement par des références.

Parmi les autres changements qui ressortent:

  • Les structures imbriquées, courantes en C, sont désormais prises en charge par Dart FFI.
  • Des optimisations de performances et de taille ont été effectuées.
  • Des outils de développement et un système de profilage de code écrit avec Flutter ont été ajoutés, ainsi que de nouveaux plugins pour développer des applications dans Dart et Flutter pour Android Studio / IntelliJ et VS Code.

Parmi les futurs projets de Dart en général, il est mentionné que dans la prochaine version, ils se concentreront principalement sur les changements de langage incrémentiels, tels que les alias de type, l'opérateur triple shift, les annotations de métadonnées génériques et la métaprogrammation statique.

Enfin si vous souhaitez en savoir plus À propos de cette nouvelle version du langage de programmation, vous pouvez vérifier les détails dans le lien suivant.

 


Le contenu de l'article adhère à nos principes de éthique éditoriale. Pour signaler une erreur, cliquez sur c'est par ici !.

Soyez le premier à commenter

Laisser un commentaire

Votre adresse e-mail ne sera pas publiée.

*

*

  1. Responsable des données : AB Internet Networks 2008 SL
  2. Finalité des données: Contrôle du SPAM, gestion des commentaires.
  3. Légitimation: votre consentement
  4. Communication des données: Les données ne seront pas communiquées à des tiers sauf obligation légale.
  5. Stockage des données: base de données hébergée par Occentus Networks (EU)
  6. Droits: à tout moment, vous pouvez limiter, récupérer et supprimer vos informations.