Sulujen asentaminen Debianiin / Ubuntuun ja johdannaisiin

Sulkeet

Suluissa on koodieditori, jonka voimme saada ilmaiseksi Gnu / Linux-jakelulle. Sulkeet Sen on luonut Adobe-yritys, vaikka se on ilmainen ohjelmisto.

Suluissa ei käytetä koodieditoria, koska se sallii vain muokata verkkokehitykseen liittyviä tiedostoja, vaikka tiedostoja ohjelmointikielistä, kuten C tai Java, voidaan myös luoda tällä editorilla, mutta sillä ei ole samoja ominaisuuksia kuin luomalla php- tai javascript-tiedostoja.

Suluissa tuetaan laajennuksia ja lisäosia, jotka mahdollistavat sen toimintojen ja työkalujen laajentamisen mielenkiintoisin asia on sen tarjoama live-näkymä. Tämän toiminnon avulla voimme nähdä kaikki muokkaamamme verkkokehitykset. Se on yksi toiminnoista, joista pidän eniten tässä editorissa ja joka saa minut valitsemaan sen ennen muita koodieditoreja, kuten Atom tai Sublime Text.

Suluissa on reaaliaikanäkymä-toiminto, joka auttaa meitä kehittämään verkkoprojektiamme

Uusin versio suluista voidaan asentaa Debian-pohjaiseen jakeluun, tähän meidän on vain mentävä virallisella verkkosivustolla ja lataa foorumiamme vastaava deb-paketti. Mutta joissakin jakeluissa, kuten Ubuntu, tämä asennusmenetelmä voi olla hankala Suluissa tarvitaan kirjasto libgcrypt11, eikä Ubunnulla ole sitä sen uusimmissa versioissa.

Tämän ongelman ratkaisemiseksi joko asennamme kirjaston itsenäisesti tai käytämme tavallista arkistoa, joka ratkaisee tämän ongelman. Valitsen henkilökohtaisesti jälkimmäisen ja webupd8-arkiston, joka on kaikki vaatimukset täyttävä arkisto. Joten avaamme päätelaitteen ja kirjoitamme seuraavan:

sudo add-apt-repository ppa:webupd8team/brackets
sudo apt update
sudo apt install brackets

Tällöin Brackets-editori asennetaan, ja muutaman minuutin asennuksen jälkeen meillä on se käyttövalmis ja web-sovellusten luomiseen, eikö olekin?

PÄIVITETTY: Adobe lopetti Bracketsin kehittämisen Microsoftin kanssa tehdyn sopimuksen jälkeen 1. syyskuuta 2021, eikä sen jälkeen ole päivitetty versiota Linuxille. Kyllä, voimme asentaa tässä selitetyn paketin (v1.13). napsahtaa (v1.11) ja Flatpak (v1.14.1). Lisää tietoa, täällä.

Artikkelin sisältö noudattaa periaatteita toimituksellinen etiikka. Ilmoita virheestä napsauttamalla täällä.

6 kommenttia, jätä omasi

Jätä kommentti

Sähköpostiosoitettasi ei julkaista.

*

*

  1. Vastaa tiedoista: AB Internet Networks 2008 SL
  2. Tietojen tarkoitus: Roskapostin hallinta, kommenttien hallinta.
  3. Laillistaminen: Suostumuksesi
  4. Tietojen välittäminen: Tietoja ei luovuteta kolmansille osapuolille muutoin kuin lain nojalla.
  5. Tietojen varastointi: Occentus Networks (EU) isännöi tietokantaa
  6. Oikeudet: Voit milloin tahansa rajoittaa, palauttaa ja poistaa tietojasi.

  1.   Angeluz dijo

    Erinomainen veli, sain ajatuksen ylevältä ostoviestillä ja olen käyttänyt atomia tähän asti, mutta olen innoissani ajatuksesta työskennellä uudestaan ​​sellaisen työkalun kanssa kuin dreamweaver

  2.   Iñaki dijo

    Olen kehittänyt Ubuntua suhteellisen vähän aikaa. Käytän tällä hetkellä pimennystä. Mutta mitä kaipaan todella ovat dreamweaver-mallit, että päivittämällä valikossa oleva linkki, tämä päivitetään kaikkiin tiedostoihin, jotka käyttävät kyseistä mallia. Onko suluissa jotain vastaavaa tai muuta ide- tai editoria?

  3.   jää dijo

    mmm Jätin täydellisemmän opetusohjelman blogiini, mikäli olet kiinnostunut, lisäämättä ppa: ta. Jos olet kiinnostunut, ilmoita heille xD

    1.    Jeesus dijo

      mutta jaa blogiisi, se olisi erittäin hyödyllistä, etsin erityisesti editoria, joka käsittelee Java-paketteja tai on sidottu jdk 8: een tai openJDK JRE: hen.

      terveiset

  4.   Javier García dijo

    Utelias avoimen lähdekoodin sovellus (ei avoimen lähdekoodin), joka tarvitsee vanhentuneen salauskirjaston, on nykyisempi, libgcrypt1.

  5.   jose dijo

    En löytänyt pakettia ...