Cómo actualizar Debian 8 Jessie a Debian 9 Stretch

Debian Logo

Debian 9 Stretch es la próxima futura versión estable de Debian, pero aunque actualmente no es recomendable por el equipo de Debian, lo cierto es que la versión es lo suficientemente estable como para utilizarla en nuestros equipos de producción.

Incluso la versión testing de Debian es considerada por muchos como una versión apta para utilizar en equipos de producción. Es por eso que os vamos a enseñar como actualizar la actual Debian 8 Jessie a la nueva Debian 9 Stretch.

Debian 9 Stretch sera la futura versión estable de Debian

Primero hemos de asegurarnos de tener la última versión de Debian (en estos momentos Debian 8.8), para ello abrimos la terminal y escribimos lo siguiente:

sudo apt-get update

sudo apt-get upgrade

sudo apt-get dist-upgrade

Una vez que hemos hecho esto, hemos de actualizar los repositorios de la distribución. Para ello escribimos en la terminal lo siguiente:

sudo nano /etc/apt/sources.list

Con lo que se abrirá el editor de texto Nano y el archivo sources.list con los repositorios de Debian. Ahora hemos de cambiar el texto de las lineas en las que aparece la palabra “Jessie” y sustituirlo por la palabra “Stretch”. Tras hacerlo, hemos de guardar los cambios. Para ello basta con pulsar la tecla Control + O y luego salimos pulsando las teclas Control + X.  Ahora hemos de repetir el primer paso, para ello abrimos la terminal y escribimos otra vez lo siguiente:

sudo apt-get update

sudo apt-get upgrade

sudo apt-get dist-upgrade

Tras esto, la distribución debería de comenzar la actualización a la nueva versión, una actualización que contiene cientos de paquetes y que necesita una conexión de alta velocidad ya que de lo contrario, podemos tardar horas en realizar tal proceso. La alternativa a este proceso sería utilizar la imagen ISO de Debian 9 Stretch, pero para eso hemos de descargar la imagen desde este enlace y modificar los repositorios para que utilice la imagen ISO.


2 comentarios

  1.   ElTioDeLaTecla dijo

    $ cat /etc/apt/sources.list
    #/etc/apt/sources.list
    $

  2.   LCNQ dijo

    Recién actualicé a Debian 9. Y ahora apt me sugiere hacer autoremove . Sucede que autoremove quiere eliminar paquetes como xorg
    “Los paquetes indicados a continuación se instalaron de forma automática y ya no son necesarios:
    … xinit xorg xsane xsane-common xscreensaver xscreensaver-data xserver-common xserver-xorg xserver-xorg-core xserver-xorg-input-all
    …Utilice «sudo apt autoremove» para eliminarlos”
    (Eso es una lista resumida de lo que me muestra en la terminal)
    ¿Alguien sabe cual puede ser el problema?
    Gracias.

Deja un comentario

Tu dirección de correo electrónico no será publicada. Los campos obligatorios están marcados con *