Una vulnerabilidad en QEMU expone al equipo anfitrión a través de la unidad de CD-ROM

qemu

QEMU es un proyecto que goza de un gran prestigio obtenido a través de los años gracias a sus buenas prestaciones, y de hecho ha sido de los primeros proyectos de virtualización que aparecieron, con el adicional de haberse mantenido siempre en el open source. Sin embargo en los últimos tiempos han aparecido algunos problemas de seguridad, que si bien no mancillan para nada su reputación deben ser tenidos en cuenta para analizar lo sucedido e intentar evitar que se repita.

Es que si en Mayo se conoció la vulnerabilidad VENOM, en Junio sucedió lo propio con el controlador PCNET, y para empeorar un poco las cosas hace pocas horas se descubrió una nueva vulnerabilidad de seguridad en QEMU, en este caso una que puede llegar a exponer a un sistema anfitrión a través de la emulación de lectora de CD-ROM, permitiendo escalar privilegios para ejecutar código malicioso.

La vulnerabilidad ha sido bautizada como CVE-2015-5154 y básicamente podemos describirla como un overflow de fila durante el procesamiento de determinados comandos ATAPI en el subsistema IDE de QEMU, lo cual permitiría a un potencial atacante tomar el control de un equipo anfitrión al poder escalar privilegios y trabajar cómodamente en el mismo. Son vulnerables las versiones x86 y x64 todos los equipos que utilizan el emulador de CD-ROM de esta herramienta de virtualización, tanto en su versión tradicional (qemu-xen-traditional) como upstream (qemu-xen), pero no lo son quienes utilizan modelos de dispositivos qemu-dm ni aquellos que utilizan sistemas de paravirtualización en modo anfitrión, como así tampoco lo son las versiones ARM de QEMU.

Para estar seguros sería conveniente evitar el uso de dispositivos de CD-ROM en entornos emulados, quitándolos o desactivándolos en las opciones de configuración, y es de esperar que en unas pocas horas haya un parche de seguridad para corregir esta vulnerabilidad (de hecho ya lo hay, pero debe ser aplicado en forma manual en lugar de poder actualizar los paquetes binarios de QEMU para las respectivas distros).


Categorías

Noticias

Willy Klew

Ingeniero en Informática, soy un fanático de Linux, Android, la programación, redes y todo lo que tenga que ver con las nuevas tecnologías. Ex... Ver perfil ›

Escribe un comentario