Servo: ya podemos probar el nuevo motor de Mozilla

servo

Hace unos pocos días Mozilla presentó a Servo, su nuevo motor de renderizado de alto rendimiento, el cual ha sido diseñado tanto para aplicaciones y sitios web como para aplicacione embebidas. Ha sido diseñado en el lenguaje de programación Rust, y entre esto y sus estándares de diseño se ha logrado una funcionalidad, rendimiento y modularidad sin precedentes, al menos de acuerdo a lo que manifiestan en su blog los ingenieros (tanto de Mozilla como de Samsung) que han estado a cargo del desarrollo de este motor. Y lo bueno es que ya podemos comenzar a probar Servo en GNU/Linux, y vamos a ver como.

Eso si, hay que tener en cuenta que estamos ante un proyecto que aún está en desarrollo y que de momento se descarga como nightly, pero además sus propios desarrolladores nos avisan que no es completamente compatible así que no se trata de una herramienta que podamos utilizar en entornos de producción. Es muy interesante la integración de una interfaz básica de navegador web que han realizado los desarrolladores ‘dentro’ de este motor de renderizado, pero hay que recordar que se trata de una funcionalidad experimental y que de ningún modo podemos considerar a Servo como un navegador en si mismo.

Dicho esto, si queremos probar Servo en GNU/Linux todo lo que tenemos que hacer es descargarlo desde los servidores de Mozilla, para guardarlo con el nombre de servo.tar.gz; luego debemos extraer la carpeta ‘servo’ del archivo, guardarla en algún lugar de nuestro sistema (por ejemplo, en /home/programas, y luego simplemente ejecutar el script llamado ‘./runservo.sh’ (sin las comillas, claro) que se encuentra dentro de dicha carpeta. Eso es todo, Servo se abrirá ante nosotros y podremos probar las bondades de este proyecto de Samsung y Mozilla que realmente tiene muy buena pinta y está comenzando a consolidarse.

Descarga Servo (Mozilla)


Categorías

Software Libre

Willy Klew

Ingeniero en Informática, soy un fanático de Linux, Android, la programación, redes y todo lo que tenga que ver con las nuevas tecnologías. Ex atleta, y usuario de Linux desde 1997. Ah, y un total enfermo del fútbol.

Un comentario

  1.   Guillermo Theler dijo

    al iniciarlo en Opensuse Leap 42.1 me da el siguiente error
    ./servo: /lib64/libcrypto.so.1.0.0: no version information available (required by ./servo)
    ./servo: /lib64/libcrypto.so.1.0.0: no version information available (required by ./servo)
    ./servo: /lib64/libssl.so.1.0.0: no version information available (required by ./servo)
    Unhandled error occured
    ReferenceError: navigator.mozSettings API is not available
    Failed to set APW state: TypeError: c.name is undefined

Escribe un comentario