Detectadas nuevas vulnerabilidades en Ubuntu

Tux sobre fondo verde de unos y ceros

Nuevo fallo de seguridad detectado en sistemas de Ubuntu, ésta vez tienen que ver con el Kernel de Linux que utilizan y con los cuáles los atacantes podían denegar el servicio y robar información privilegiada

Hace unos días, habíamos publicado una noticia en la cual decía que se habían detectado vulnerabilidades en sistemas operativos Ubuntu, pues éstos días se ha detectado otro fallo de seguridad catalogado como grave.

El error de seguridad ésta vez se trata de una vulnerabilidad en el Kernel de Linux de las siguientes versiones de Ubuntu: Ubuntu 14.04 LTS Trusty Tahr y Ubuntu 15.04 Vivid Velvet. Fueron exactamente dos fallos en cada versión y fueron descubiertos por usuarios.Por fortuna ya han sido corregidos siendo necesario actualizar

En la versión 14.04, se descubrieron los fallos hace un par de días y eran los siguientes.

  • El usuario Benjamin Randazzo descubrió que un usuario local podría escalar privilegios y robar información privada a través del Kernel debido a un fallo en un controlador multisistema.
  • Marc-André Lureau ha descubierto que el Kernel de Linux de ésta versión no había reservado ni limitado el espacio que puede ocupar el archivo donde se guarda el registro, entonces se podía denegar el servicio del sistema con un ataque DoS a éste archivo.

En la versión 15.04, se han descubierto hace escasas horas, son muy similares a las que ofrecía la versión 14.04 y fueron descubiertas por los mismo usuarios.

  • Benjamin Randazzo detectó una fuga de información en el Kernel debido al fallo del controlador multisistema del kernel de Linux, gracias a esto un usuario puede robar información privada.
  • Marc-André Lureau descubrió que el mismo fallo que descubrió en la versión 14.04 LTS también se producía aquí,es decir que no se reservaba espacio al archivo de logs, por lo cual se podía hacer una denegación de servicio.

Por supuesto éstas vulnerabilidades afectan a todas las versiones de Ubuntu, ya sean Ubuntu, Lubuntu, Edubuntu,Xubuntu…y debemos actualizar inmediatamente para una mayor seguridad.

Para ello, accederemos a la consola de comandos y teclearemos el clásico comando de sudo apt-get-update y el de sudo apt-get upgrade, de ésta forma ya estaremos a salvo de los atacantes.

 


Categorías

Noticias
Etiquetas

azpe

Redactor apasionado por la tecnología al que le gusta compartir conocimientos y experiencias con el mundo y futuro administrador de sistemas informáticos en red.

15 comentarios

  1.   Hugo dijo

    ¿Este fallo solo afecta a la distrito Ubuntu? o es a todas como (Fedora,Debian, OpenSuse, RedHat, etc…)

    1. apt-get upgrade es para actualizar apps y el sistema (sin cambiar de distribución), apt-get dist-upgrade es para actualizar (cambiar) la distro, si tienes 14.04, al usar dist-upgrade se actualizará a 14.10, si quieres actualizar a 15.04 tienes que usar dist-upgrade en 14.04 y en 14.10.

      1.    azpe dijo

        Fallo técnico jaja, lo cambio ahora.
        Saludos

      2.    Javier dijo

        No es exacto lo que mencionas. El comando apt-get dist-upgrade solo actualiza el Kernel. Por ejemplo si tenemos un Linux Kernel 3.16.50 se actualizaraá 3.16.51. Si la versión de distro en Ubuntu 14.04 después del comando mencionado seguirá siendo Ubuntu 14.04. Yo no utilizo las actualizaciones automáticas, sino que siempre actualizo desde la terminal (sudo apt-get update & sudo apt-get upgrade & sudo apt-get dist-upgrade).

        Saludos

    2.    azpe dijo

      Ubuntu únicamente, pero en todas sus variables (Ubuntu Mate,Xubuntu…)
      Saludos

  2.   Mario Pérez dijo

    Soy un poco nuevo en esto, pero el comando que viene hasta el final no es para actualizar la distribución, ejemplo de 14.04 a 15.04, que pasa si quiero estar protegido pero no quiero actualizar de version??.

    Saludos

  3.   fernan dijo

    Hola:
    Si es sudo apt-get upgrade pues con dist-upgrade es para subir la versión de la distribución.
    Saludos.

  4.   Jesus Carpio dijo

    Donde esta su Dios ahora… soy usuario Linux desde hace 15 años y la mayor parte del tiempo me jacte de tener un sistema “Seguro” No hay S.O. seguro, creo que windows es inseguro por que es mas atractivo para los hackers buscar sus vulnerabilidades, ya que mas gente lo utiliza, ahora que linux ha dado un salto importante, es que empezaremos a descubrir mas y mas fallos graves.

    1.    azpe dijo

      Ya pero no vayamos a comparar, la diferencia es que los errores de Linux se corrigen y los de Windows se esconden jaja.
      Saludos

  5.   MirrorBlue dijo

    Mi dios esta en el cielo.
    Me aburrí de ocupar windows por tanto pantallazo azul, error tras error :(
    Actualizaciones incompletas que hacían que fallara lo que en algún momento “funcionaba”
    Gastos y gastos en compra de antivirus y licencias para hacer mis tareas y trabajo.
    Ahora GNU/Linux es el presente y ha capturado las miradas de aquellos incrédulos que no creían en el, por lo que ahora se comen su amargas palabras y su orgullo teniendo que valerse de el, copiándolo, haciendo una distrito de el(jajajajajaja) para seguir subsistiendo y no quedar en el pasado.
    Nada es perfecto, pero poco a poco vamos desechando aquellas cosas que no nos sirven y se van quedando en el camino.
    Saludos a todos los Linuxeros de corazón!!!!!
    Y felicidades a los creadores de este blog.

  6.   Javier dijo

    Por cierto, espero me puedan ayudar. Desde antier llev+e a cabo las actualizaciones pero surgió un problema con la actualización del Kernel. Cuando actualiza me arroja lo siguiente:

    iemex@iemex-AM1MHP:~$ sudo apt-get upgrade
    Leyendo lista de paquetes… Hecho
    Creando árbol de dependencias
    Leyendo la información de estado… Hecho
    Calculando la actualización… Listo
    0 actualizados, 0 se instalarán, 0 para eliminar y 0 no actualizados.
    6 no instalados del todo o eliminados.
    Se utilizarán 0 B de espacio de disco adicional después de esta operación.
    ¿Desea continuar? [S/n] s
    Configurando linux-image-extra-3.16.0-50-generic (3.16.0-50.66~14.04.1) …
    run-parts: executing /etc/kernel/postinst.d/apt-auto-removal 3.16.0-50-generic /boot/vmlinuz-3.16.0-50-generic
    run-parts: executing /etc/kernel/postinst.d/dkms 3.16.0-50-generic /boot/vmlinuz-3.16.0-50-generic
    run-parts: executing /etc/kernel/postinst.d/initramfs-tools 3.16.0-50-generic /boot/vmlinuz-3.16.0-50-generic
    update-initramfs: Generating /boot/initrd.img-3.16.0-50-generic

    gzip: stdout: No space left on device
    E: mkinitramfs failure cpio 141 gzip 1
    update-initramfs: failed for /boot/initrd.img-3.16.0-50-generic with 1.
    run-parts: /etc/kernel/postinst.d/initramfs-tools exited with return code 1
    dpkg: error al procesar el paquete linux-image-extra-3.16.0-50-generic (–configure):
    el subproceso instalado el script post-installation devolvió el código de salida de error 1
    dpkg: problemas de dependencias impiden la configuración de linux-image-generic-lts-utopic:
    linux-image-generic-lts-utopic depende de linux-image-extra-3.16.0-50-generic; sin embargo:
    El paquete `linux-image-extra-3.16.0-50-generic’ no está configurado todavía.

    dpkg: error al procesar el paquete linux-image-generic-lts-utopic (–configure):
    problemas de dependencias – se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de linux-generic-lts-utopic:
    linux-generic-lts-utopic depende de linux-image-generic-lts-utopic (= 3.16.0.50.41); sin embargo:
    El paquete `linux-image-generic-lts-utopic’ no está configurado todavía.

    dpkg: error al procesar el paquete linux-generic-lts-utopic (–configure):
    problemas de dependencias – se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de linux-signed-image-3.16.0-50-generic:
    linux-signed-image-3.16.0-50-generic depende de linux-image-extra-3.16.0-50-generic (= 3.16.0-50.66~14.04.1); sin embargNo se escribió un informe «apport» porque el mensaje de error indica que es un mensaje de error asociado a un fallo previo.
    No se escribió un informe «apport» porque el mensaje de error indica que es un mensaje de error asociado a un fallo previo.
    No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
    No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
    No se escribió ningún informe «apport» porque ya se ha alcanzado el valor de «MaxReports»
    o:
    El paquete `linux-image-extra-3.16.0-50-generic’ no está configurado todavía.

    dpkg: error al procesar el paquete linux-signed-image-3.16.0-50-generic (–configure):
    problemas de dependencias – se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de linux-signed-image-generic-lts-utopic:
    linux-signed-image-generic-lts-utopic depende de linux-signed-image-3.16.0-50-generic; sin embargo:
    El paquete `linux-signed-image-3.16.0-50-generic’ no está configurado todavía.

    dpkg: error al procesar el paquete linux-signed-image-generic-lts-utopic (–configure):
    problemas de dependencias – se deja sin configurar
    dpkg: problemas de dependencias impiden la configuración de linux-signed-generic-lts-utopic:
    linux-signed-generic-lts-utopic depende de linux-signed-image-generic-lts-utopic (= 3.16.0.50.41); sin embargo:
    El paquete `linux-signed-image-generic-lts-utopic’ no está configurado todavía.

    dpkg: error al procesar el paquete linux-signed-generic-lts-utopic (–configure):
    problemas de dependencias – se deja sin configurar
    Se encontraron errores al procesar:
    linux-image-extra-3.16.0-50-generic
    linux-image-generic-lts-utopic
    linux-generic-lts-utopic
    linux-signed-image-3.16.0-50-generic
    linux-signed-image-generic-lts-utopic
    linux-signed-generic-lts-utopic
    E: Sub-process /usr/bin/dpkg returned an error code (1)
    iemex@iemex-AM1MHP:~$

    Mi Ubuntu es 14.04.2 LTS AMD64. La verdad no se que hacer, no se si se podrá corregir en la próxima actualización del Kernel que envíe Canonical o que. Si alguien me puede asesorar lo agradeceré pues no tengo mucho tiempo usando un sistema GNU/Linux.

  7.   dhouard dijo

    No soy experto en Ubuntu pero parece que te has quedado sin espacio en la partición /boot, donde está alojado el kernel (el archivo vmlinuz). Echa un ojo a ver si tienes varios kernel en ese directorio (los diferenciarás por el número de versión) y, en el caso de un compañero de trabajo, lo arreglé borrando el más antiguo, así como los initrd y demás archivo asociados con la misma numeración (siempre que veas que está repetido).

    Por otra parte, no se si habrá alguna herramienta en Ubuntu para eliminar kernels antiguos de una manera más segura.

    1.    Javier dijo

      Muchas gracias.

      De hecho es un Ubuntu de recién instalación (una semana) y solo he tenido una actualización de Kernel. Elimino los kernels antiguos por medio de Ubuntu Tweak. Sin embargo no he eliminado el kernel anterior por lo que comente. Por eso mi duda. En otros equipos he llegado a tener hasta 4 kernels antiguos y nunca me había pasado.

  8.   christiams dijo

    hola javier yo tengo el mismo problema y no puedo solucionarlo, ya lo solucionaste? gracias

    1.    Javier dijo

      Pues como dijo dhouard no hay espacio en /boot, pero creo que es porque en la compu que lo instalé cree un sector de arranque EFI, talvez es tu caso también pues deje un espacio reducidocom recomienda (no mas de 40 kb). Solución: sólo es eliminar el kernel antiguo. Yo usé Ubuntu Tweak y en el momento que está eliminando el kernel antiguo instala el componente que no podía instalar y asunto arreglado.

      Saludos

Escribe un comentario